aboutsummaryrefslogtreecommitdiff
path: root/science/libaec/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-01 01:47:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-01 01:47:21 +0000
commitf94c4248392d693bbd7c80a0b77c337636bbccad (patch)
treef92c313c51e7f26d2fef7d9764a1c0111cab6d42 /science/libaec/Makefile
parent60b4f2bd0ef6b3cc0843ae84195e10f9433c60dc (diff)
Notes
Diffstat (limited to 'science/libaec/Makefile')
-rw-r--r--science/libaec/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/libaec/Makefile b/science/libaec/Makefile
new file mode 100644
index 000000000000..ee84a8224364
--- /dev/null
+++ b/science/libaec/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libaec
+PORTVERSION= 1.0.0
+CATEGORIES= science
+MASTER_SITES= https://gitlab.dkrz.de/k202009/libaec/repository/archive.tar.bz2?ref=v${PORTVERSION}&dummy=/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Adaptive entropy coding library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= hdf-szip-
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+USES= autoreconf libtool tar:bz2
+
+GL_TAGNAME= 351b61ebdfd2a3c02c7227df4a13d106d79418f8
+WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}-${GL_TAGNAME}
+
+.include <bsd.port.mk>