aboutsummaryrefslogtreecommitdiff
path: root/science/libcint/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-14 19:55:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-14 20:15:02 +0000
commitb1f9b88ed149bbf85e467686a9dcce91e1142224 (patch)
tree5aa5618568eeb128fecb18fa1a129f2a45e81394 /science/libcint/Makefile
parentdac4f0201d015336ca9fe980a00f78c82e00efa6 (diff)
downloadports-b1f9b88ed149bbf85e467686a9dcce91e1142224.tar.gz
ports-b1f9b88ed149bbf85e467686a9dcce91e1142224.zip
Diffstat (limited to 'science/libcint/Makefile')
-rw-r--r--science/libcint/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/science/libcint/Makefile b/science/libcint/Makefile
index 0aed7709ff55..dc0ef8cb00a8 100644
--- a/science/libcint/Makefile
+++ b/science/libcint/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libcint
DISTVERSIONPREFIX= v
-DISTVERSION= 4.1.2
+DISTVERSION= 4.1.3
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -12,9 +12,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libopenblas.so:math/openblas
USES= cmake blaslapack:openblas
+USE_LDCONFIG= yes
+
USE_GITHUB= yes
GH_ACCOUNT= sunqm
-USE_LDCONFIG= yes
PLIST_FILES= include/cint.h \
include/cint_funcs.h \
@@ -22,4 +23,10 @@ PLIST_FILES= include/cint.h \
lib/libcint.so.${PORTVERSION:R:R} \
lib/libcint.so.${PORTVERSION}
+do-test: # tests fail: https://github.com/sunqm/libcint/issues/54
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DENABLE_TEST:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
.include <bsd.port.mk>