aboutsummaryrefslogtreecommitdiff
path: root/science/libghemical
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-17 04:42:03 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-17 04:42:03 +0000
commit764b454de0cb0ea02d655ab2f77a0843a65c326c (patch)
tree3c924af119641b55767b3847d80ea3669a1e51f1 /science/libghemical
parent8fe778037520c28b401fa9c471f764decee42c9e (diff)
downloadports-764b454de0cb0ea02d655ab2f77a0843a65c326c.tar.gz
ports-764b454de0cb0ea02d655ab2f77a0843a65c326c.zip
Notes
Diffstat (limited to 'science/libghemical')
-rw-r--r--science/libghemical/Makefile10
-rw-r--r--science/libghemical/files/ghemical-f2c.sh16
-rw-r--r--science/libghemical/files/patch-f2c23
3 files changed, 28 insertions, 21 deletions
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 734d3934c2a6..26def8dc7fdc 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -6,7 +6,7 @@
PORTNAME= libghemical
PORTVERSION= 2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://www.uku.fi/~thassine/projects/download/ \
http://bioinformatics.org/ghemical/download/
@@ -17,7 +17,9 @@ COMMENT= Support libraries of science/ghemical port
BUILD_DEPENDS= openbabel:${PORTSDIR}/science/openbabel \
mopac7:${PORTSDIR}/biology/mopac
-LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc
+LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc \
+ f2c:${PORTSDIR}/lang/f2c
+
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
@@ -29,6 +31,7 @@ WANT_FORTRAN=yes #dummy but future use
BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
@@ -49,7 +52,4 @@ CONFIGURE_ARGS+= --enable-mopac7 --enable-mpqc --enable-openbabel --with-blas="-
USE_AUTOTOOLS= autoconf:259
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
-pre-configure:
- @cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
-
.include <bsd.port.post.mk>
diff --git a/science/libghemical/files/ghemical-f2c.sh b/science/libghemical/files/ghemical-f2c.sh
deleted file mode 100644
index 9a1a37200c41..000000000000
--- a/science/libghemical/files/ghemical-f2c.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Make new c sources from fortran sources, restore changes,
-# made by Tommi Hassinen (3 comments are corrected additionally).
-# Should be started in miniMOPAC directory.
-
-f2c fortran/*.f
-cp fortran/*.c ./
-sed -e 's,/\* fortran/\(.*\)\.f -- translated by f2c (version 20000817),/\* \1.f -- translated by f2c (version 19991025),' \
--e 's,dscal_,mMdscal_,g' \
--e 's,dswap_,mMdswap_,g' \
--e 's,daxpy_,mMdaxpy_,g' \
--i '' *.c
-mv etime.c etime.c.orig
-head -18 etime.c.orig > etime.c
-echo '#include <time.h>' >> etime.c
-tail +19 etime.c.orig >> etime.c
diff --git a/science/libghemical/files/patch-f2c b/science/libghemical/files/patch-f2c
new file mode 100644
index 000000000000..be95ed1790cd
--- /dev/null
+++ b/science/libghemical/files/patch-f2c
@@ -0,0 +1,23 @@
+We need -lf2c here... we will never depend on g2c.
+--- Makefile.in~ Wed Jan 17 12:08:54 2007
++++ Makefile.in Wed Jan 17 12:39:20 2007
+@@ -128,7 +128,7 @@
+ LTLIBOBJS = @LTLIBOBJS@
+ MAKEINFO = @MAKEINFO@
+ MOPAC7_CFLAGS = @MOPAC7_CFLAGS@
+-MOPAC7_LIBS = @MOPAC7_LIBS@
++MOPAC7_LIBS = @MOPAC7_LIBS@ -lf2c
+ OBJEXT = @OBJEXT@
+ PACKAGE = @PACKAGE@
+ PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+
+why we need it here again?
+--- libghemical.pc.in~ Tue Aug 1 19:46:49 2006
++++ libghemical.pc.in Wed Jan 17 13:15:00 2007
+@@ -6,5 +6,5 @@
+ Name: libghemical
+ Description: A library that contains molecular modelling functionality.
+ Version: @LIBVERSION@
+-Libs: -L${libdir} -lghemical @SC_LIBS@ @MOPAC7_LIBS@
++Libs: -L${libdir} -lghemical @SC_LIBS@ @MOPAC7_LIBS@ -lf2c
+ Cflags: -I${includedir}/ghemical @SC_CPPFLAGS@ @MOPAC7_CFLAGS@