aboutsummaryrefslogtreecommitdiff
path: root/science/libkml
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-19 11:06:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-19 11:06:20 +0000
commit1e5ee3f9c9e512d995acc99d3119299e665e8fd1 (patch)
tree2f4bb79a63d67d9f94b4738b87cb8c4c8dba1f50 /science/libkml
parent18192c1285733646eeefb83400f98d8036ec2bd3 (diff)
downloadports-1e5ee3f9c9e512d995acc99d3119299e665e8fd1.tar.gz
ports-1e5ee3f9c9e512d995acc99d3119299e665e8fd1.zip
Notes
Diffstat (limited to 'science/libkml')
-rw-r--r--science/libkml/Makefile2
-rw-r--r--science/libkml/pkg-plist105
2 files changed, 105 insertions, 2 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index 90d667207aa0..31f5c9d9016a 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -30,8 +30,6 @@ USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
USES= cmake pathfix
-PORTEXAMPLES= *
-
USE_GITHUB= yes
EXAMPLES_CMAKE_BOOL= BUILD_EXAMPLES INSTALL_EXAMPLES
diff --git a/science/libkml/pkg-plist b/science/libkml/pkg-plist
index 2a84646eb746..d350eb80788f 100644
--- a/science/libkml/pkg-plist
+++ b/science/libkml/pkg-plist
@@ -158,3 +158,108 @@ lib/libkmlxsd.so
lib/libkmlxsd.so.1
lib/libkmlxsd.so.1.3.0
libdata/pkgconfig/libkml.pc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/checklinks.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circlegen.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/countkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/createkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/domviewer.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/balloonwalker.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/change.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/clone.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/csv2kml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/csvinfo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/import.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/inlinestyles.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/kml2kmz.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/kmlfile.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/kmzchecklinks.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/oldschema.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/parsebig.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/printstyle.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/splitstyles.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/engine/streamkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gpx/gpxtracktokml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gx/featuretour.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gx/gpxfly.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/helloattrs.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/helloenum.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellofeatures.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellofolder.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellogeometry.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellohref.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellokmz.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/csvurl2gmap.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/curlfetch.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/curlfetch.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/getgmapkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/getgsheetcsv.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/getgsheetkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/gsheet2gmap.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/kmlwalk.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/kmzfetch.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/listfeed.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/listgdocs.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/listgmaps.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/listgphotos.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/prompt.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/resolvestyle.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/searchgmap.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/uploadgmap.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/uploadgmapcsv.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/uploadgmapkml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/uploadgsheet.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellonet/xsdprint.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/helloregion.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/helloworld.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/java/CreateFolder.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/java/CreatePlacemark.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/java/WalkFeatures.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/java/run.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/abstractview.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/allstyles.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/altitudemode.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/attrs.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/extendeddata.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/folder.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/inline-stylemap.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/kmlsamples.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/lines.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/model.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/networklink.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/networklinkcontrol.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/photooverlay.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/polygons2d.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/region.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/sky.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/snippets.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/styles.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/time.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kml/unknown-elements.kml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsebuf.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsekml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsens.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/prettykml.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/print.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/print.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printgeometry.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/helloenum.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/hellogeometry.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/hellolocation.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/helloplacemark.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/hellopoint.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/hellovector.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/hellowalk.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/parse_point_placemark.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regionator/csvregionator.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regionator/kmlregionator.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sharedstyles.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplifylines.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sortplacemarks.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/kml-aliases.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdchildren.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdcoverage.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdelements.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdenums.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdfind.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsd/xsdtypes.cc