aboutsummaryrefslogtreecommitdiff
path: root/science/lm/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-09 21:16:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-09 21:16:02 +0000
commit2104ac7ca63cc086f13f1e341cb06de111b748a7 (patch)
tree4a877d198fc977d76e4ed2fe951eb394d175bb23 /science/lm/Makefile
parent526e658f293d99829cfeb781017c2e96507669f2 (diff)
downloadports-2104ac7ca63cc086f13f1e341cb06de111b748a7.tar.gz
ports-2104ac7ca63cc086f13f1e341cb06de111b748a7.zip
Notes
Diffstat (limited to 'science/lm/Makefile')
-rw-r--r--science/lm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/lm/Makefile b/science/lm/Makefile
index d9bbdf526c9e..0a806db298f5 100644
--- a/science/lm/Makefile
+++ b/science/lm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libprotobuf.so:devel/protobuf \
libsz.so:science/szip
-USES= gettext-runtime gmake localbase python
+USES= gettext-runtime gmake
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
CXXFLAGS+= -DLINUX
@@ -35,6 +35,7 @@ MPI_VARS= XUSE_MPI=1
MPI_VARS_OFF= XUSE_MPI=0
MPI_LIB_DEPENDS= libmpich.so:net/mpich2
+PYTHON_USES= python
PYTHON_VARS= XUSE_PYTHON=1
PYTHON_VARS_OFF= XUSE_PYTHON=0
PYTHON_CXXFLAGS= -I${PYTHON_SITELIBDIR}/numpy/core/include