aboutsummaryrefslogtreecommitdiff
path: root/science/mcstas/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-18 14:17:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-18 14:17:20 +0000
commit3322825ec969cf6d7e73759794d28a1dad1819b8 (patch)
tree361fb5119d49211a702b3695f5717b5dcdec542b /science/mcstas/Makefile
parentc9a35507f6230031bbf17e4b26eb4c31bf049e6e (diff)
Notes
Diffstat (limited to 'science/mcstas/Makefile')
-rw-r--r--science/mcstas/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/science/mcstas/Makefile b/science/mcstas/Makefile
new file mode 100644
index 000000000000..10693949c3f3
--- /dev/null
+++ b/science/mcstas/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mcstas
+# Date created: Apr 26, 2004
+# Whom: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
+#
+# $FreeBSD$
+
+PORTNAME= mcstas
+PORTVERSION= 1.8
+CATEGORIES= science
+MASTER_SITES= http://mcstas.risoe.dk/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= Joerg.Pulz@frm2.tum.de
+COMMENT= A neutron ray-trace simulation package
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
+ ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+
+STRIP=
+USE_GZIP= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+NO_MTREE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PERL_ARCHNAME!= perl -V:archname
+
+PLIST_SUB+= PERL_PORT=perl5 PERL_ARCHNAME=${PERL_ARCHNAME:S/archname='//:S/';//}
+
+post-configure:
+ @cd ${WRKSRC}; make pgplot
+
+.include <bsd.port.mk>