aboutsummaryrefslogtreecommitdiff
path: root/science/mcstas
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-11-12 02:29:59 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-11-12 02:29:59 +0000
commit706407ee138045db628883e1726ff45d7fadc915 (patch)
tree0061c317946c8d5e303e4488ab5db51a7495576c /science/mcstas
parent4785db28391f1f093a3c26d2ed3fba2548523e9e (diff)
downloadports-706407ee138045db628883e1726ff45d7fadc915.tar.gz
ports-706407ee138045db628883e1726ff45d7fadc915.zip
Notes
Diffstat (limited to 'science/mcstas')
-rw-r--r--science/mcstas/Makefile32
-rw-r--r--science/mcstas/distinfo4
-rw-r--r--science/mcstas/files/pkg-deinstall.in (renamed from science/mcstas/pkg-deinstall)10
-rw-r--r--science/mcstas/files/pkg-install.in (renamed from science/mcstas/pkg-install)2
-rw-r--r--science/mcstas/pkg-descr6
-rw-r--r--science/mcstas/pkg-plist154
6 files changed, 88 insertions, 120 deletions
diff --git a/science/mcstas/Makefile b/science/mcstas/Makefile
index 28f8edcfc879..3b2351440e37 100644
--- a/science/mcstas/Makefile
+++ b/science/mcstas/Makefile
@@ -2,39 +2,25 @@
# $FreeBSD$
PORTNAME= mcstas
-PORTVERSION= 2.1
+PORTVERSION= 2.2a
CATEGORIES= science
-MASTER_SITES= http://download.mcstas.org/${PORTNAME}-${PORTVERSION}/unix/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-DISTFILES= McStas-${PORTVERSION}-UNIX-src.tar.gz
-DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= http://download.mcstas.org/${PORTNAME}-${PORTVERSION}/unix/McStas-${PORTVERSION}-UNIX-src/
+DISTNAME= mcstas-${PORTVERSION}-src
MAINTAINER= erkn@fysik.dtu.dk
COMMENT= Monte Carlo neutron ray tracing package
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-
-USES= cmake gmake bison:build
-#should perhaps use the toolchain file - but remember the arch
+USES= bison:build cmake gmake
CMAKE_ARGS= "-Denable_mcstas=1"
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-# this is necessary since mcxtrace and mcstas are packaged in a
-# single tarball in which the kernel, component library, manual,
-# and tool tarballs reside
-post-fetch:
-.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
- cd ${DISTDIR}/${DIST_SUBDIR};\
- ${TAR} --strip-components 1 -xzf ${DISTFILES} McStas-2.1-UNIX-src/${DISTNAME}.tar.gz;
-.endif
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-deinstall pkg-install
post-stage:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/2.1/bin/mcstas
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/2.1/bin/mcformat
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/${PORTVERSION}/bin/mcformat
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/${PORTVERSION}/bin/mcstas
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/mcstas/distinfo b/science/mcstas/distinfo
index 1060d2c16f9f..543b860af46b 100644
--- a/science/mcstas/distinfo
+++ b/science/mcstas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mcstas/McStas-2.1-UNIX-src.tar.gz) = 70d5b33d67ea9b8e4c276b4e8c7ece907ac28ec63f523d7e0cbcc9e425b4aaf4
-SIZE (mcstas/McStas-2.1-UNIX-src.tar.gz) = 27807879
+SHA256 (mcstas-2.2a-src.tar.gz) = 7f8cca7ceea87e4b99c17ee16e4f1e6fd89712d2de1ba61ab97a2cd7ea0f8b9d
+SIZE (mcstas-2.2a-src.tar.gz) = 347943
diff --git a/science/mcstas/pkg-deinstall b/science/mcstas/files/pkg-deinstall.in
index 9db0cb3c3765..47d2ae9a5a9c 100644
--- a/science/mcstas/pkg-deinstall
+++ b/science/mcstas/files/pkg-deinstall.in
@@ -1,25 +1,19 @@
#!/bin/sh
-PKG_PREFIX=${PKG_PREFIX:-/usr/local}
+PKG_PREFIX=${PKG_PREFIX:-%%PREFIX%%}
if [ $# -ne 2 ]; then
echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
exit 1
fi
-pname=${1%-*}
-pversion=${1##*-}
-
-#echo the extracted port name is $pname
-#echo the extracted port version is $pversion
-
execs="mcstas mcformat"
case $2 in
DEINSTALL)
if [ ! -f "${PKG_PREFIX}/bin" ]; then
- echo "Deinstalling links to ${1} executables in ${PKG_PREFIX}/bin.";
+ echo "Deinstalling links to executables in ${PKG_PREFIX}/bin.";
for target in ${execs}; do
rm ${PKG_PREFIX}/bin/${target};
done
diff --git a/science/mcstas/pkg-install b/science/mcstas/files/pkg-install.in
index 242933726294..a3fe95daaf97 100644
--- a/science/mcstas/pkg-install
+++ b/science/mcstas/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
-PKG_PREFIX=${PKG_PREFIX:-/usr/local}
+PKG_PREFIX=${PKG_PREFIX:-%%PREFIX%%}
if [ $# -ne 2 ]; then
echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
diff --git a/science/mcstas/pkg-descr b/science/mcstas/pkg-descr
index 5d47fb370ab2..e829e09506de 100644
--- a/science/mcstas/pkg-descr
+++ b/science/mcstas/pkg-descr
@@ -1,7 +1,7 @@
-Monte Carlo ray tracing simulations of neutron experiments.
+McStas - Monte Carlo ray tracing simulations of neutron experiments.
McStas is a tool for simulating neutron instrumentation and experiments
-using a ray-tracing formalism. Currently the main use of McStas is
-in the field of instrument design.
+using a ray-tracing formalism. Currently the main use of McStas is in the
+field of instrument design.
WWW: http://www.mcstas.org
diff --git a/science/mcstas/pkg-plist b/science/mcstas/pkg-plist
index 278e44225c91..bddf4a6dab04 100644
--- a/science/mcstas/pkg-plist
+++ b/science/mcstas/pkg-plist
@@ -1,84 +1,72 @@
-mcstas/2.1/LGPL
-mcstas/2.1/LICENSE.LIB
-mcstas/2.1/NOMENCLATURE
-mcstas/2.1/README
-mcstas/2.1/bin/mcformat
-mcstas/2.1/bin/mcstas
-mcstas/2.1/data/Al.nxs
-mcstas/2.1/data/Cu.nxs
-mcstas/2.1/doc/man/man1/mcformat-2.1.1
-mcstas/2.1/doc/man/man1/mcstas-2.1.1
-mcstas/2.1/environment
-mcstas/2.1/module
-mcstas/2.1/share/adapt_tree-lib.c
-mcstas/2.1/share/adapt_tree-lib.h
-mcstas/2.1/share/general.c
-mcstas/2.1/share/general.h
-mcstas/2.1/share/interoff-lib.c
-mcstas/2.1/share/interoff-lib.h
-mcstas/2.1/share/interpolation/array-utils.c
-mcstas/2.1/share/interpolation/array-utils.h
-mcstas/2.1/share/interpolation/natural/README
-mcstas/2.1/share/interpolation/natural/delaunay.c
-mcstas/2.1/share/interpolation/natural/delaunay.h
-mcstas/2.1/share/interpolation/natural/example.c
-mcstas/2.1/share/interpolation/natural/natural.c
-mcstas/2.1/share/interpolation/natural/natural.h
-mcstas/2.1/share/interpolation/natural/predicates.c
-mcstas/2.1/share/interpolation/natural/utils-extra.c
-mcstas/2.1/share/interpolation/natural/utils-extra.h
-mcstas/2.1/share/interpolation/natural/vertex.h
-mcstas/2.1/share/interpolation/nearest/README
-mcstas/2.1/share/interpolation/nearest/example.c
-mcstas/2.1/share/interpolation/nearest/kdtree.c
-mcstas/2.1/share/interpolation/nearest/kdtree.h
-mcstas/2.1/share/interpolation/nearest/vertex.h
-mcstas/2.1/share/interpolation/resample.c
-mcstas/2.1/share/interpolation/resample.h
-mcstas/2.1/share/intersection.c
-mcstas/2.1/share/intersection.h
-mcstas/2.1/share/mccode-r.c
-mcstas/2.1/share/mccode-r.h
-mcstas/2.1/share/mcstas-r.c
-mcstas/2.1/share/mcstas-r.h
-mcstas/2.1/share/nxslib/README.TXT
-mcstas/2.1/share/nxslib/nxs.c
-mcstas/2.1/share/nxslib/nxs.h
-mcstas/2.1/share/nxslib/sgclib.c
-mcstas/2.1/share/nxslib/sgfind.c
-mcstas/2.1/share/nxslib/sghkl.c
-mcstas/2.1/share/nxslib/sginfo.h
-mcstas/2.1/share/nxslib/sgio.c
-mcstas/2.1/share/nxslib/sgsi.c
-mcstas/2.1/share/pol-lib.c
-mcstas/2.1/share/pol-lib.h
-mcstas/2.1/share/read_table-lib.c
-mcstas/2.1/share/read_table-lib.h
-mcstas/2.1/share/ref-lib.c
-mcstas/2.1/share/ref-lib.h
-mcstas/2.1/share/vitess-lib.c
-mcstas/2.1/share/vitess-lib.h
-@dir mcstas/2.1/bin
-@dir mcstas/2.1/contrib/Gas_tables
-@dir mcstas/2.1/contrib/ISIS_tables
-@dir mcstas/2.1/contrib/Neutronics
-@dir mcstas/2.1/contrib/doc
-@dir mcstas/2.1/contrib
-@dir mcstas/2.1/data
-@dir mcstas/2.1/doc/man/man1
-@dir mcstas/2.1/doc/man
-@dir mcstas/2.1/doc
-@dir mcstas/2.1/examples
-@dir mcstas/2.1/misc
-@dir mcstas/2.1/monitors
-@dir mcstas/2.1/obsolete
-@dir mcstas/2.1/optics
-@dir mcstas/2.1/samples
-@dir mcstas/2.1/share/interpolation/natural
-@dir mcstas/2.1/share/interpolation/nearest
-@dir mcstas/2.1/share/interpolation
-@dir mcstas/2.1/share/nxslib
-@dir mcstas/2.1/share
-@dir mcstas/2.1/sources
-@dir mcstas/2.1
+mcstas/%%PORTVERSION%%/LGPL
+mcstas/%%PORTVERSION%%/LICENSE.LIB
+mcstas/%%PORTVERSION%%/NOMENCLATURE
+mcstas/%%PORTVERSION%%/README
+mcstas/%%PORTVERSION%%/bin/mcformat
+mcstas/%%PORTVERSION%%/bin/mcstas
+mcstas/%%PORTVERSION%%/data/Al.nxs
+mcstas/%%PORTVERSION%%/data/Cu.nxs
+mcstas/%%PORTVERSION%%/doc/man/man1/mcformat-%%PORTVERSION%%.1
+mcstas/%%PORTVERSION%%/doc/man/man1/mcstas-%%PORTVERSION%%.1
+mcstas/%%PORTVERSION%%/environment
+mcstas/%%PORTVERSION%%/module
+mcstas/%%PORTVERSION%%/share/adapt_tree-lib.c
+mcstas/%%PORTVERSION%%/share/adapt_tree-lib.h
+mcstas/%%PORTVERSION%%/share/general.c
+mcstas/%%PORTVERSION%%/share/general.h
+mcstas/%%PORTVERSION%%/share/interoff-lib.c
+mcstas/%%PORTVERSION%%/share/interoff-lib.h
+mcstas/%%PORTVERSION%%/share/interpolation/array-utils.c
+mcstas/%%PORTVERSION%%/share/interpolation/array-utils.h
+mcstas/%%PORTVERSION%%/share/interpolation/natural/README
+mcstas/%%PORTVERSION%%/share/interpolation/natural/delaunay.c
+mcstas/%%PORTVERSION%%/share/interpolation/natural/delaunay.h
+mcstas/%%PORTVERSION%%/share/interpolation/natural/example.c
+mcstas/%%PORTVERSION%%/share/interpolation/natural/natural.c
+mcstas/%%PORTVERSION%%/share/interpolation/natural/natural.h
+mcstas/%%PORTVERSION%%/share/interpolation/natural/predicates.c
+mcstas/%%PORTVERSION%%/share/interpolation/natural/utils-extra.c
+mcstas/%%PORTVERSION%%/share/interpolation/natural/utils-extra.h
+mcstas/%%PORTVERSION%%/share/interpolation/natural/vertex.h
+mcstas/%%PORTVERSION%%/share/interpolation/nearest/README
+mcstas/%%PORTVERSION%%/share/interpolation/nearest/example.c
+mcstas/%%PORTVERSION%%/share/interpolation/nearest/kdtree.c
+mcstas/%%PORTVERSION%%/share/interpolation/nearest/kdtree.h
+mcstas/%%PORTVERSION%%/share/interpolation/nearest/vertex.h
+mcstas/%%PORTVERSION%%/share/interpolation/resample.c
+mcstas/%%PORTVERSION%%/share/interpolation/resample.h
+mcstas/%%PORTVERSION%%/share/intersection.c
+mcstas/%%PORTVERSION%%/share/intersection.h
+mcstas/%%PORTVERSION%%/share/mccode-r.c
+mcstas/%%PORTVERSION%%/share/mccode-r.h
+mcstas/%%PORTVERSION%%/share/mcstas-r.c
+mcstas/%%PORTVERSION%%/share/mcstas-r.h
+mcstas/%%PORTVERSION%%/share/nxslib/README.TXT
+mcstas/%%PORTVERSION%%/share/nxslib/nxs.c
+mcstas/%%PORTVERSION%%/share/nxslib/nxs.h
+mcstas/%%PORTVERSION%%/share/nxslib/sgclib.c
+mcstas/%%PORTVERSION%%/share/nxslib/sgfind.c
+mcstas/%%PORTVERSION%%/share/nxslib/sghkl.c
+mcstas/%%PORTVERSION%%/share/nxslib/sginfo.h
+mcstas/%%PORTVERSION%%/share/nxslib/sgio.c
+mcstas/%%PORTVERSION%%/share/nxslib/sgsi.c
+mcstas/%%PORTVERSION%%/share/pol-lib.c
+mcstas/%%PORTVERSION%%/share/pol-lib.h
+mcstas/%%PORTVERSION%%/share/read_table-lib.c
+mcstas/%%PORTVERSION%%/share/read_table-lib.h
+mcstas/%%PORTVERSION%%/share/ref-lib.c
+mcstas/%%PORTVERSION%%/share/ref-lib.h
+mcstas/%%PORTVERSION%%/share/vitess-lib.c
+mcstas/%%PORTVERSION%%/share/vitess-lib.h
+@dir mcstas/%%PORTVERSION%%/bin
+@dir mcstas/%%PORTVERSION%%/data
+@dir mcstas/%%PORTVERSION%%/doc/man/man1
+@dir mcstas/%%PORTVERSION%%/doc/man
+@dir mcstas/%%PORTVERSION%%/doc
+@dir mcstas/%%PORTVERSION%%/share/interpolation/natural
+@dir mcstas/%%PORTVERSION%%/share/interpolation/nearest
+@dir mcstas/%%PORTVERSION%%/share/interpolation
+@dir mcstas/%%PORTVERSION%%/share/nxslib
+@dir mcstas/%%PORTVERSION%%/share
+@dir mcstas/%%PORTVERSION%%
@dir mcstas