aboutsummaryrefslogtreecommitdiff
path: root/science/meep
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-18 06:01:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-18 06:01:25 +0000
commitb22ecee081fc903b85bdb8dcb11218f93a347169 (patch)
treedc4997e9efe9d942648ad25537bf686ed214357c /science/meep
parent932b1434740ee62e2f11d3faf0385f821d2a7b98 (diff)
Notes
Diffstat (limited to 'science/meep')
-rw-r--r--science/meep/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
index 4ccbfc7b44c5..92bf99aeaf9e 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -3,24 +3,31 @@
PORTNAME= meep
PORTVERSION= 1.2.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/meep/
MAINTAINER= devel@stasyan.com
COMMENT= FDTD simulation software to model electromagnetic systems
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= harminv:science/harminv \
gsed:textproc/gsed
-LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
libblas.so:math/blas \
+ libguile-2.0.so:lang/guile2 \
libctl.so:science/libctl \
- libhdf5.so:science/hdf5
+ libgc-threaded.so:devel/boehm-gc-threaded \
+ libgsl.so:math/gsl \
+ libhdf5.so:science/hdf5 \
+ liblapack.so:math/lapack
RUN_DEPENDS= harminv:science/harminv
+USES= fortran gettext gmake iconv libtool pathfix pkgconfig
GNU_CONFIGURE= yes
USE_GCC= yes
-USES= fortran gettext gmake iconv libtool pathfix pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= CC="${CC}" CXX="${CXX}"
@@ -42,7 +49,7 @@ PLIST_SUB+= MPI="@comment " NOMPI=""
.endif
.if ${PORT_OPTIONS:MMPICH2}
-LIB_DEPENDS+= libmpich.so.8:net/mpich2
+LIB_DEPENDS+= libmpich.so:net/mpich2
CONFIGURE_ENV+= MPICXX=${LOCALBASE}/bin/mpicc
CFLAGS+= -I${LOCALBASE}/include
.endif