aboutsummaryrefslogtreecommitdiff
path: root/science/metaf2xml
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-09-23 06:37:27 +0000
committerWen Heping <wen@FreeBSD.org>2016-09-23 06:37:27 +0000
commit74323f53027a087f92673234a5ec96dd46d40b5e (patch)
treef89062c36df1cc13c3ef9c3bba8d1ba49a79888d /science/metaf2xml
parent3946d031aaf0da9c284e3fd54f85ee77110f1683 (diff)
Notes
Diffstat (limited to 'science/metaf2xml')
-rw-r--r--science/metaf2xml/Makefile14
-rw-r--r--science/metaf2xml/distinfo5
-rw-r--r--science/metaf2xml/pkg-descr20
-rw-r--r--science/metaf2xml/pkg-plist5
4 files changed, 25 insertions, 19 deletions
diff --git a/science/metaf2xml/Makefile b/science/metaf2xml/Makefile
index 7d89f03ec338..2aa75f95b99e 100644
--- a/science/metaf2xml/Makefile
+++ b/science/metaf2xml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= metaf2xml
-PORTVERSION= 1.58
+PORTVERSION= 2.0
CATEGORIES= science perl5
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -17,19 +17,29 @@ OPTIONS_SUB= yes
APACHE_DESC= Install Apache config file for metaf2xml (depends on Apache)
MAKE_ARGS= CGI_BIN_DIR=${WWWDIR}/cgi-bin \
+ CGI_DATA_DIR=/var/tmp \
+ CGI_LOG_DIR=/var/tmp \
HTDOCS_DIR=${WWWDIR}/htdocs \
METAF2XML=${PREFIX} \
METAF2XML_LIB=${PREFIX}/${SITE_PERL_REL} \
METAF2XML_DOC=${DOCSDIR} \
+ METAF2XML_MAN=${PREFIX}/man \
METAF2XML_XSL=${DATADIR} \
BUILD_ROOT=${STAGEDIR}
NO_BUILD= yes
+NO_ARCH= yes
USES= perl5 shebangfix tar:tgz
USE_PERL5= install run
SHEBANG_FILES= metaf.pl metaf2xml.pl metafsrc2raw.pl
PLIST_SUB= VERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.22
+RUN_DEPENDS+= p5-CGI>0:www/p5-CGI
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE}
@@ -37,4 +47,4 @@ USE_APACHE_RUN= 22+
MAKE_ARGS+= CONF_DIR=${PREFIX}/${APACHEETCDIR}/Includes
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/metaf2xml/distinfo b/science/metaf2xml/distinfo
index 3cd302703cb3..c8e855fae8f4 100644
--- a/science/metaf2xml/distinfo
+++ b/science/metaf2xml/distinfo
@@ -1,2 +1,3 @@
-SHA256 (metaf2xml-1.58.tgz) = 87a906e7f81a0eead7f85cb6674c498b3e8b7ea1133a2c07b952d1915db2a4df
-SIZE (metaf2xml-1.58.tgz) = 361267
+TIMESTAMP = 1474612314
+SHA256 (metaf2xml-2.0.tgz) = 9fbb25644f168327c91fb5a867f34926234b39144ab741311d66b804757157ce
+SIZE (metaf2xml-2.0.tgz) = 371661
diff --git a/science/metaf2xml/pkg-descr b/science/metaf2xml/pkg-descr
index 7c7278c4db01..f9e116519827 100644
--- a/science/metaf2xml/pkg-descr
+++ b/science/metaf2xml/pkg-descr
@@ -1,13 +1,13 @@
-metaf2xml can download, parse and decode aviation routine weather
-reports (METAR, SPECI, SAO), aerodrome forecasts (TAF), synoptic
-observations (SYNOP), observations from buoys (BUOY) and
-meteorological reports from aircrafts (AMDAR). The extracted data can
-be written as XML or passed to a user-defined function (all done in
-Perl).
+metaf2xml can download, parse and decode aviation routine weather reports
+(METAR, SPECI, SAO), aerodrome forecasts (TAF), synoptic observations
+(SYNOP), observations from buoys (BUOY) and meteorological reports from
+aircrafts (AMDAR). Data can also be taken from decoded BUFR messages.
+The extracted data can be written as XML or passed to a user-defined
+function (all done in Perl).
-It also provides XSLT style sheets to convert the XML to plain
-language (text, HTML), or XML with different schemas. A web-based
-(CGI) user interface can be used to download and display up-to-date
-weather data from NOAA, Ogimet, and other sources.
+It also provides XSLT style sheets to convert the XML to plain language
+(text, HTML), or XML with different schemas. A web-based (CGI) user
+interface can be used to download and display up-to-date weather data from
+NOAA, Ogimet, and other sources.
WWW: http://metaf2xml.sourceforge.net/
diff --git a/science/metaf2xml/pkg-plist b/science/metaf2xml/pkg-plist
index 811263df4909..1b100200c818 100644
--- a/science/metaf2xml/pkg-plist
+++ b/science/metaf2xml/pkg-plist
@@ -15,14 +15,11 @@ man/man3/metaf2xml::src2raw.3pm.gz
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
%%DATADIR%%/metaf-fullhtml.xsl
%%DATADIR%%/metaf-html.xsl
%%DATADIR%%/metaf-lang-de.xml
%%DATADIR%%/metaf-lang-en.xml
%%DATADIR%%/metaf-lang-es.xml
-%%DATADIR%%/metaf-lang-pl.xml
-%%DATADIR%%/metaf-lang-pt-br.xml
%%DATADIR%%/metaf-lang-ru.xml
%%DATADIR%%/metaf-lang.xml
%%DATADIR%%/metaf-sum-html.xsl
@@ -40,8 +37,6 @@ man/man3/metaf2xml::src2raw.3pm.gz
%%WWWDIR%%/htdocs/metaf-lang-de.xml
%%WWWDIR%%/htdocs/metaf-lang-en.xml
%%WWWDIR%%/htdocs/metaf-lang-es.xml
-%%WWWDIR%%/htdocs/metaf-lang-pl.xml
-%%WWWDIR%%/htdocs/metaf-lang-pt-br.xml
%%WWWDIR%%/htdocs/metaf-lang-ru.xml
%%WWWDIR%%/htdocs/metaf-lang.xml
%%WWWDIR%%/htdocs/metaf-sum-html.xsl