aboutsummaryrefslogtreecommitdiff
path: root/science/metaphysicl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-18 04:59:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-18 04:59:15 +0000
commit07b50b05daaa68203ce5858961b5690aa2df506f (patch)
tree52da213c29c1cfe9feaa8f8d83c19f1b55ae6bb5 /science/metaphysicl
parent22df9677d29beb2561db6987b6847dc1bd654a42 (diff)
Notes
Diffstat (limited to 'science/metaphysicl')
-rw-r--r--science/metaphysicl/Makefile25
-rw-r--r--science/metaphysicl/distinfo3
-rw-r--r--science/metaphysicl/pkg-descr16
-rw-r--r--science/metaphysicl/pkg-plist51
4 files changed, 95 insertions, 0 deletions
diff --git a/science/metaphysicl/Makefile b/science/metaphysicl/Makefile
new file mode 100644
index 000000000000..bc988c7b7512
--- /dev/null
+++ b/science/metaphysicl/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= MetaPhysicL
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0-23
+DISTVERSIONSUFFIX= -g3e4e88f
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Metaprogramming, operator-overloaded classes for numerical simulations
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake libtool
+USE_GITHUB= yes
+GH_ACCOUNT= roystgnr
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-static
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmetaphysicl.so.0.0.0
+
+.include <bsd.port.mk>
diff --git a/science/metaphysicl/distinfo b/science/metaphysicl/distinfo
new file mode 100644
index 000000000000..3a7cba299168
--- /dev/null
+++ b/science/metaphysicl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524023355
+SHA256 (roystgnr-MetaPhysicL-v0.2.0-23-g3e4e88f_GH0.tar.gz) = 870d5762e788197ebec7a9453b378c8d9a47fa65dfe8d961569273c531e94439
+SIZE (roystgnr-MetaPhysicL-v0.2.0-23-g3e4e88f_GH0.tar.gz) = 374202
diff --git a/science/metaphysicl/pkg-descr b/science/metaphysicl/pkg-descr
new file mode 100644
index 000000000000..4ccfa2352821
--- /dev/null
+++ b/science/metaphysicl/pkg-descr
@@ -0,0 +1,16 @@
+MetaPhysicL is a set of template classes and metaprogramming tools
+useful for the generation of physics codes which are optimized at
+compile-time.
+
+This includes many classes which are designed to be compatible with
+generic codes written for plain numeric data types like float and
+double, but which may provide more featureful output:
+* DualNumber, for automatic differentiation.
+* NumberArray, for vectorization.
+* SparseNumberArray and SparseNumberStruct, for homogeneous or
+ heterogeneous sparse vectors whose structure can be inferred at
+ compile time.
+* EquationSet, for the automatic assembly of physics equations into
+ evaluation codes.
+
+WWW: https://github.com/roystgnr/MetaPhysicL
diff --git a/science/metaphysicl/pkg-plist b/science/metaphysicl/pkg-plist
new file mode 100644
index 000000000000..9939969e490a
--- /dev/null
+++ b/science/metaphysicl/pkg-plist
@@ -0,0 +1,51 @@
+bin/metaphysicl_version
+include/metaphysicl/compare_types.h
+include/metaphysicl/ct_set.h
+include/metaphysicl/ct_types.h
+include/metaphysicl/dualderivatives.h
+include/metaphysicl/dualdynamicsparsenumberarray.h
+include/metaphysicl/dualdynamicsparsenumberarray_decl.h
+include/metaphysicl/dualdynamicsparsenumbervector.h
+include/metaphysicl/dualdynamicsparsenumbervector_decl.h
+include/metaphysicl/dualexpression.h
+include/metaphysicl/dualnamedarray.h
+include/metaphysicl/dualnumber.h
+include/metaphysicl/dualnumber_decl.h
+include/metaphysicl/dualnumberarray.h
+include/metaphysicl/dualnumbervector.h
+include/metaphysicl/dualshadow.h
+include/metaphysicl/dualshadowdynamicsparsearray.h
+include/metaphysicl/dualshadowdynamicsparsevector.h
+include/metaphysicl/dualshadowsparsestruct.h
+include/metaphysicl/dualshadowsparsevector.h
+include/metaphysicl/dualshadowvector.h
+include/metaphysicl/dualsparsenumberarray.h
+include/metaphysicl/dualsparsenumberstruct.h
+include/metaphysicl/dualsparsenumbervector.h
+include/metaphysicl/dynamicsparsenumberarray.h
+include/metaphysicl/dynamicsparsenumberarray_decl.h
+include/metaphysicl/dynamicsparsenumberbase.h
+include/metaphysicl/dynamicsparsenumberbase_decl.h
+include/metaphysicl/dynamicsparsenumbervector.h
+include/metaphysicl/dynamicsparsenumbervector_decl.h
+include/metaphysicl/metaphysicl_asserts.h
+include/metaphysicl/metaphysicl_cast.h
+include/metaphysicl/metaphysicl_exceptions.h
+include/metaphysicl/metaphysicl_version.h
+include/metaphysicl/metaprogramming.h
+include/metaphysicl/namedindexarray.h
+include/metaphysicl/numberarray.h
+include/metaphysicl/numbervector.h
+include/metaphysicl/physics.h
+include/metaphysicl/raw_type.h
+include/metaphysicl/shadownumber.h
+include/metaphysicl/sparsenumberarray.h
+include/metaphysicl/sparsenumberstruct.h
+include/metaphysicl/sparsenumberutils.h
+include/metaphysicl/sparsenumbervector.h
+include/metaphysicl/testable.h
+lib/libmetaphysicl.so
+lib/libmetaphysicl.so.0
+lib/libmetaphysicl.so.0.0.0
+libdata/pkgconfig/metaphysicl.pc
+share/aclocal/metaphysicl.m4