aboutsummaryrefslogtreecommitdiff
path: root/science/minc2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-30 12:05:08 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-30 12:05:08 +0000
commit26c255eb054c2b34cb29a14cce1c806b1bff2008 (patch)
treeb953b3ef03ef35e115a57e397381f07c0a9d4102 /science/minc2/Makefile
parentfdd1538a7b54ae17bbed6d63febbf87797a3a0ef (diff)
downloadports-26c255eb054c2b34cb29a14cce1c806b1bff2008.tar.gz
ports-26c255eb054c2b34cb29a14cce1c806b1bff2008.zip
Notes
Diffstat (limited to 'science/minc2/Makefile')
-rw-r--r--science/minc2/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index ec961a33e97e..41ed616e2b81 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -16,24 +16,27 @@
# Of course, the netcdf port must be installed first.
PORTNAME= minc
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 2.0.09
CATEGORIES= science biology
-MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
+MASTER_SITES= http://www.bic.mni.mcgill.ca/users/bert/ \
http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Medical Imaging NetCDF
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
+ hdf5.0:${PORTSDIR}/science/hdf5
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GCC= 3.2+
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-static=yes --enable-shared=yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFLICTS= minc-1*
+LATEST_LINK= minc2
MAN1= dcm2mnc.1 \
ecattominc.1 \
@@ -42,12 +45,15 @@ MAN1= dcm2mnc.1 \
mincaverage.1 \
minccalc.1 \
mincconcat.1 \
+ mincconvert.1 \
minccopy.1 \
mincdiff.1 \
mincedit.1 \
mincexpand.1 \
mincextract.1 \
+ mincgen.1 \
mincheader.1 \
+ minchistory.1 \
mincinfo.1 \
minclookup.1 \
mincmakescalar.1 \
@@ -69,10 +75,9 @@ MAN1= dcm2mnc.1 \
voxeltoworld.1 \
xfmconcat.1 \
xfminvert.1
-
MAN3= ParseArgv.3
post-install:
- @${CAT} ${PKGMESSAGE}
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>