aboutsummaryrefslogtreecommitdiff
path: root/science/minc2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-07-10 13:59:11 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-07-10 13:59:11 +0000
commit0381bbee56ea8700431adeed9cbd1a8e5843de03 (patch)
tree09be6c9efb27ce0e59c370379302c505933b902d /science/minc2/Makefile
parentff1e1381cdba10b86ba2d9e24798c276735ca18c (diff)
downloadports-0381bbee56ea8700431adeed9cbd1a8e5843de03.tar.gz
ports-0381bbee56ea8700431adeed9cbd1a8e5843de03.zip
Notes
Diffstat (limited to 'science/minc2/Makefile')
-rw-r--r--science/minc2/Makefile62
1 files changed, 10 insertions, 52 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index a89eb8fa42e9..17e6261a59ae 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -1,10 +1,5 @@
-############################################################################
-# New ports collection Makefile for: minc 1.x (Medical Imaging NetCDF)
-# Date created: 21 Dec 2005
-# Whom: jbacon
-#
+# Created by: jbacon
# $FreeBSD$
-#
############################################################################
# http://www.bic.mni.mcgill.ca/software/minc/
@@ -16,67 +11,30 @@
# Of course, the netcdf port must be installed first.
PORTNAME= minc
-PORTVERSION= 2.0.18
+PORTVERSION= 2.2.00
CATEGORIES= science biology
-MASTER_SITES= http://www.nitrc.org/frs/download.php/801/
+MASTER_SITES= http://packages.bic.mni.mcgill.ca/tgz/
MAINTAINER= jwbacon@tds.net
COMMENT= Medical Imaging NetCDF
+LICENSE= AS-IS
+LICENSE_NAME= AS-IS
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror pkg-mirror
+
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf \
hdf5:${PORTSDIR}/science/hdf5
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+USES= cmake:outsource bison:build
CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -DH5_USE_16_API
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+CMAKE_ARGS= -DMINC2_BUILD_SHARED_LIBS:BOOL=YES
CONFLICTS= minc-1* zh-tk-[0-9]*
LATEST_LINK= minc2
-MAN1= dcm2mnc.1 \
- ecattominc.1 \
- invert_raw_image.1 \
- minc_modify_header.1 \
- mincaverage.1 \
- minccalc.1 \
- mincconcat.1 \
- mincconvert.1 \
- minccopy.1 \
- mincdiff.1 \
- mincedit.1 \
- mincexpand.1 \
- mincextract.1 \
- mincgen.1 \
- mincheader.1 \
- minchistory.1 \
- mincinfo.1 \
- minclookup.1 \
- mincmakescalar.1 \
- mincmakevector.1 \
- mincmath.1 \
- mincpik.1 \
- mincresample.1 \
- mincreshape.1 \
- mincstats.1 \
- minctoecat.1 \
- minctoraw.1 \
- mincview.1 \
- mincwindow.1 \
- mnc2nii.1 \
- nii2mnc.1 \
- rawtominc.1 \
- transformtags.1 \
- upet2mnc.1 \
- vff2mnc.1 \
- voxeltoworld.1 \
- xfmconcat.1 \
- xfmflip.1 \
- xfminvert.1
-
-MAN3= ParseArgv.3
-
post-install:
${CAT} ${PKGMESSAGE}