aboutsummaryrefslogtreecommitdiff
path: root/science/minc2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-02-12 15:30:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-02-12 15:30:03 +0000
commit3b5fa65f18da8fe6046d6fb6324ebd08df638180 (patch)
tree13d6a3ccaeeca8015a73c7994548cf44e4343ad4 /science/minc2/Makefile
parentd446f531b35791798c65cdfe7b40d5698934b33b (diff)
downloadports-3b5fa65f18da8fe6046d6fb6324ebd08df638180.tar.gz
ports-3b5fa65f18da8fe6046d6fb6324ebd08df638180.zip
Notes
Diffstat (limited to 'science/minc2/Makefile')
-rw-r--r--science/minc2/Makefile80
1 files changed, 80 insertions, 0 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
new file mode 100644
index 000000000000..a9bc2faa5917
--- /dev/null
+++ b/science/minc2/Makefile
@@ -0,0 +1,80 @@
+############################################################################
+# New ports collection Makefile for: minc 1.x (Medical Imaging NetCDF)
+# Date created: 21 Dec 2005
+# Whom: jbacon
+#
+# $FreeBSD$
+#
+
+############################################################################
+# http://www.bic.mni.mcgill.ca/software/minc/
+# is the ultimate source for MINC, and will always contain the latest
+# source release. If this port is not up to date enough for you,
+# you can download the latest sources and build manually. On FreeBSD,
+# you must configure with the environment variable LDFLAGS set to
+# ${LOCALBASE}/lib so that the configure script will find libnetcdf.
+# Of course, the netcdf port must be installed first.
+
+PORTNAME= minc
+PORTVERSION= 1.4
+CATEGORIES= science biology
+MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
+ http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Medical Imaging NetCDF
+
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+
+INSTALLS_SHLIB= yes
+
+USE_AUTOTOOLS= libtool:15
+
+# Build parameters
+#WRKSRC= ${WRKDIR}/minc-${PORTVERSION}
+
+MAN1= dcm2mnc.1 \
+ ecattominc.1 \
+ invert_raw_image.1 \
+ minc_modify_header.1 \
+ mincaverage.1 \
+ minccalc.1 \
+ mincconcat.1 \
+ minccopy.1 \
+ mincdiff.1 \
+ mincedit.1 \
+ mincexpand.1 \
+ mincextract.1 \
+ mincheader.1 \
+ mincinfo.1 \
+ minclookup.1 \
+ mincmakescalar.1 \
+ mincmakevector.1 \
+ mincmath.1 \
+ mincpik.1 \
+ mincresample.1 \
+ mincreshape.1 \
+ mincstats.1 \
+ minctoecat.1 \
+ minctoraw.1 \
+ mincview.1 \
+ mincwindow.1 \
+ mnc2nii.1 \
+ nii2mnc.1 \
+ rawtominc.1 \
+ transformtags.1 \
+ upet2mnc.1 \
+ voxeltoworld.1 \
+ xfmconcat.1 \
+ xfminvert.1
+MAN3= ParseArgv.3
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>