aboutsummaryrefslogtreecommitdiff
path: root/science/minc2
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2012-07-20 16:33:32 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2012-07-20 16:33:32 +0000
commite0ee3df12dbdaaf6ace84b50ed938389989af3a5 (patch)
tree23bfd0ab23a51fe3928a6af409eddddafb31347e /science/minc2
parent731e041cb5d0b8ad7802381f6edbedb3c34ad9ab (diff)
downloadports-e0ee3df12dbdaaf6ace84b50ed938389989af3a5.tar.gz
ports-e0ee3df12dbdaaf6ace84b50ed938389989af3a5.zip
Notes
Diffstat (limited to 'science/minc2')
-rw-r--r--science/minc2/Makefile15
-rw-r--r--science/minc2/distinfo4
-rw-r--r--science/minc2/files/patch-conversion__minctoecat__machine_indep.c11
-rw-r--r--science/minc2/pkg-descr2
-rw-r--r--science/minc2/pkg-message2
-rw-r--r--science/minc2/pkg-plist2
6 files changed, 25 insertions, 11 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index f71cf2f28839..a89eb8fa42e9 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -16,25 +16,23 @@
# Of course, the netcdf port must be installed first.
PORTNAME= minc
-PORTVERSION= 2.0.09
-PORTREVISION= 1
+PORTVERSION= 2.0.18
CATEGORIES= science biology
-MASTER_SITES= http://www.bic.mni.mcgill.ca/users/bert/ \
- http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+MASTER_SITES= http://www.nitrc.org/frs/download.php/801/
MAINTAINER= jwbacon@tds.net
COMMENT= Medical Imaging NetCDF
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf \
- hdf5.0:${PORTSDIR}/science/hdf5
+ hdf5:${PORTSDIR}/science/hdf5
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -DH5_USE_16_API
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
-CONFLICTS= minc-1*
+CONFLICTS= minc-1* zh-tk-[0-9]*
LATEST_LINK= minc2
MAN1= dcm2mnc.1 \
@@ -71,9 +69,12 @@ MAN1= dcm2mnc.1 \
rawtominc.1 \
transformtags.1 \
upet2mnc.1 \
+ vff2mnc.1 \
voxeltoworld.1 \
xfmconcat.1 \
+ xfmflip.1 \
xfminvert.1
+
MAN3= ParseArgv.3
post-install:
diff --git a/science/minc2/distinfo b/science/minc2/distinfo
index c7e7434f3dfa..c471ce509e14 100644
--- a/science/minc2/distinfo
+++ b/science/minc2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (minc-2.0.09.tar.gz) = b55907a5dd26c1b98b39f6cb81133336d7c794d4f7d4ad38b02561a9cc489390
-SIZE (minc-2.0.09.tar.gz) = 1418085
+SHA256 (minc-2.0.18.tar.gz) = 674cc89c43edfdb1957251c0124ea83252740c667cf3c4d9fc6183dcdb10f3e5
+SIZE (minc-2.0.18.tar.gz) = 1628038
diff --git a/science/minc2/files/patch-conversion__minctoecat__machine_indep.c b/science/minc2/files/patch-conversion__minctoecat__machine_indep.c
new file mode 100644
index 000000000000..b1e87762e631
--- /dev/null
+++ b/science/minc2/files/patch-conversion__minctoecat__machine_indep.c
@@ -0,0 +1,11 @@
+--- conversion/minctoecat/machine_indep.c.orig 2012-07-20 17:16:13.000000000 +0200
++++ conversion/minctoecat/machine_indep.c 2012-07-20 17:17:48.000000000 +0200
+@@ -84,7 +84,7 @@
+ bufr[1] = ret >>16;
+ }
+ #else /* BIG ENDIAN : sun hp sgi*/
+-ftovaxf(orig,number)
++void ftovaxf(orig,number)
+ unsigned short number[2];
+ float orig;
+ {
diff --git a/science/minc2/pkg-descr b/science/minc2/pkg-descr
index 1c7b09a15c9a..0730d1b37440 100644
--- a/science/minc2/pkg-descr
+++ b/science/minc2/pkg-descr
@@ -4,7 +4,7 @@ Neelin at the McConnell Brain Imaging Centre of the Montreal Neurological
Institute. Many others have contributed to the design and implementation
MINC over the years.
-WWW: http://www.bic.mni.mcgill.ca/software/minc/
+WWW: http://www.bic.mni.mcgill.ca/ServicesSoftware/MINC
Port maintainer: Jason W. Bacon
jwbacon@tds.net
diff --git a/science/minc2/pkg-message b/science/minc2/pkg-message
index 5c529217fd13..cc3dd854da2b 100644
--- a/science/minc2/pkg-message
+++ b/science/minc2/pkg-message
@@ -4,5 +4,5 @@ port maintainer: jwbacon@tds.net
For MINC usage, please visit the MINC WEB site at
-http://www.bic.mni.mcgill.ca/software/minc/
+http://www.bic.mni.mcgill.ca/ServicesSoftware/MINC
=============================================================================
diff --git a/science/minc2/pkg-plist b/science/minc2/pkg-plist
index c1d540edba89..0af479a6913b 100644
--- a/science/minc2/pkg-plist
+++ b/science/minc2/pkg-plist
@@ -33,9 +33,11 @@ bin/nii2mnc
bin/rawtominc
bin/transformtags
bin/upet2mnc
+bin/vff2mnc
bin/voxeltoworld
bin/worldtovoxel
bin/xfmconcat
+bin/xfmflip
bin/xfminvert
include/ParseArgv.h
include/minc.h