aboutsummaryrefslogtreecommitdiff
path: root/science/mol2ps/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-19 11:02:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-19 11:02:46 +0000
commit5b58e2bcf96450e10b266ea172a953eef3a6b448 (patch)
tree4f77a25f5d3975becb7d5854ef23594c809143c7 /science/mol2ps/Makefile
parent4d72a8bd988f8b3579f3f3f6e36e11eb8b6034b6 (diff)
downloadports-5b58e2bcf96450e10b266ea172a953eef3a6b448.tar.gz
ports-5b58e2bcf96450e10b266ea172a953eef3a6b448.zip
Notes
Diffstat (limited to 'science/mol2ps/Makefile')
-rw-r--r--science/mol2ps/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/science/mol2ps/Makefile b/science/mol2ps/Makefile
new file mode 100644
index 000000000000..d9f2e6890000
--- /dev/null
+++ b/science/mol2ps/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mol2ps
+# Date created: 23 Feb 2009
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mol2ps
+PORTVERSION= 0.1e
+CATEGORIES= science
+MASTER_SITES= http://merian.pch.univie.ac.at/pch/download/chemistry/${PORTNAME}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .pas
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Read molecular structure files and generate Postscript output
+
+USE_FPC= yes
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/
+do-build:
+ cd ${WRKDIR}; ${LOCALBASE}/bin/fpc ${DISTFILES} -S2 -O3 -Op3
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${FILESDIR}/color.conf ${DATADIR}
+
+.include <bsd.port.mk>