aboutsummaryrefslogtreecommitdiff
path: root/science/mpqc/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-09 15:01:48 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-09 15:01:48 +0000
commitd575b690b9380b466147a91361edc2abd3bd512c (patch)
treee2e26d9e2d7310334780c817de5a9e9ad92ccfd9 /science/mpqc/Makefile
parentdd2322a3a24541b956de14fdd5b8dbfb636456f5 (diff)
downloadports-d575b690b9380b466147a91361edc2abd3bd512c.tar.gz
ports-d575b690b9380b466147a91361edc2abd3bd512c.zip
Notes
Diffstat (limited to 'science/mpqc/Makefile')
-rw-r--r--science/mpqc/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 14f469085324..d94f92319489 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mpqc
@@ -30,10 +31,10 @@ WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -lcblas -latlas
+BLAS= -lf77blas -latlas
LAPACK= -lalapack
.else
-LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
@@ -49,6 +50,9 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259
+WANT_FORTRAN=yes
+USE_GCC=4.2+
+
.if defined(WITH_ICC)
CC= ${LOCALBASE}/intel_cc_80/bin/icc
CXX= ${LOCALBASE}/intel_cc_80/bin/icpc