aboutsummaryrefslogtreecommitdiff
path: root/science/mpqc/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-07 02:23:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-07 02:23:54 +0000
commitb03a452d5a004bb7e37372a16e8baa70315187b2 (patch)
tree53237680f9124a31f70ddcf88d1a13bfbcf255f3 /science/mpqc/Makefile
parentcd27d6a4a403cda54a58e349430f176921e4b05c (diff)
science/mpqc: Add -lmpich to LDFLAGS: this fixes science/libghemical build
science/libghemical was failing because libSCgroup.so needs MPI_* symbols but wasn't linked to libmpich.so.
Notes
Notes: svn path=/head/; revision=479174
Diffstat (limited to 'science/mpqc/Makefile')
-rw-r--r--science/mpqc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 0e53c0e4a84a..a5799e39c682 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 38
+PORTREVISION= 39
CATEGORIES= science parallel
MASTER_SITES= SF
@@ -50,6 +50,7 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:lang/icc
MPI_CONFIGURE_ENABLE= parallel
MPI_LIB_DEPENDS= libmpich.so:net/mpich2
+MPI_LDFLAGS= -lmpich # build fails to supply libmpich.so to link
OPTIFLAGS_CFLAGS= -ffast-math
OPTIFLAGS_CXXFLAGS= -ffast-math