aboutsummaryrefslogtreecommitdiff
path: root/science/mpqc
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-27 07:31:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-27 07:31:27 +0000
commitf7e89e5ee1ed480960215c3749fd1727e4eda67d (patch)
treebfa4ef6da6429a09bd50c9864e488df752bdf3b5 /science/mpqc
parentf2d0304169f860bc91971fa1f203180420ececac (diff)
downloadports-f7e89e5ee1ed480960215c3749fd1727e4eda67d.tar.gz
ports-f7e89e5ee1ed480960215c3749fd1727e4eda67d.zip
Notes
Diffstat (limited to 'science/mpqc')
-rw-r--r--science/mpqc/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 05c960ce2a4e..4806cd2f3dce 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -20,13 +20,11 @@ COMMENT= The massively parallel quantum computing library and program
LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
atlas:${PORTSDIR}/math/atlas
-.include <bsd.port.pre.mk>
-
USE_BISON= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS= --with-cc=${CC} \
--with-cxx=${CXX} \
- --with-f77=${F77} \
+ --with-f77=${FC} \
--with-libdirs=-L${LOCALBASE}/lib \
--with-blas="-lf77blas -latlas" \
--with-lapack="-lalapack -lcblas" \
@@ -39,7 +37,8 @@ ALL_TARGET= # empty
PLIST_SUB+= VERSION=${PORTVERSION}
MPQC_COMMAND= ${PREFIX}/bin/mpqc
-.include "${MASTERDIR}/files/manpages"
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages"
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
@@ -59,7 +58,7 @@ do-install:
@cd ${WRKDIR}/${PORTNAME}-man-${PORTVERSION}/man3/ ; ${TAR} -chf - . | \
${TAR} -xf - -C ${PREFIX}/man/man3/
@${MKDIR} ${PREFIX}/share/mpqc/ref
- @cd ${WRKDIR}/ref/ && ${TAR} -chf - . | \
+ @cd ${WRKDIR}/ref/ ; ${TAR} -chf - . | \
${TAR} -xf - -C ${PREFIX}/share/mpqc/ref
post-install: