aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf-fortran/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-15 21:08:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-15 21:08:21 +0000
commitde5ef775c93fe873b48a2d3b8a79430e36abe50c (patch)
treee4253abc8f1d49458992686198180d48a2cba110 /science/netcdf-fortran/Makefile
parent43f175e06c5c742d61cfba1b19ff60514b23abee (diff)
downloadports-de5ef775c93fe873b48a2d3b8a79430e36abe50c.tar.gz
ports-de5ef775c93fe873b48a2d3b8a79430e36abe50c.zip
Notes
Diffstat (limited to 'science/netcdf-fortran/Makefile')
-rw-r--r--science/netcdf-fortran/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/science/netcdf-fortran/Makefile b/science/netcdf-fortran/Makefile
index 3c1a17e859c1..c5aa8e2cad82 100644
--- a/science/netcdf-fortran/Makefile
+++ b/science/netcdf-fortran/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
PORTNAME= netcdf-fortran
-PORTVERSION= 4.2
-PORTREVISION= 3
+PORTVERSION= 4.4.0
CATEGORIES= science
-MASTER_SITES= https://github.com/Unidata/${PORTNAME}/archive/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fortran library for machine-independent, array-oriented data access
@@ -20,19 +17,24 @@ GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= MAKEINFOFLAGS=--no-split
MAKE_JOBS_UNSAFE= yes
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
+#USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
USE_LDCONFIG= yes
USES= fortran libtool makeinfo pathfix
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
-INFO= netcdf-f77 netcdf-f90
+#INFO= netcdf-f77 netcdf-f90
-AUTOMAKE_ARGS= --add-missing
-LIBTOOLIZE_ARGS=--copy --force --install
-PATHFIX_MAKEFILEIN= Makefile.am
+#AUTOMAKE_ARGS= --add-missing
+#LIBTOOLIZE_ARGS=--copy --force --install
+#PATHFIX_MAKEFILEIN= Makefile.am
+
+USE_GITHUB= yes
+GH_ACCOUNT= Unidata
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= ccd65b4
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnetcdff.so.5
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnetcdff.so.6
regression-test test: build
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check