aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-05-15 05:40:57 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-05-15 05:40:57 +0000
commit1493eb07a1fff8831c84aef5ac9189ca490e045b (patch)
treead5b90d277a100ac8b0f2add5410ab039ff462fe /science/netcdf/Makefile
parent1bc7dbaf0096e54bd435d7aaf5065ce0d7ac794e (diff)
Notes
Diffstat (limited to 'science/netcdf/Makefile')
-rw-r--r--science/netcdf/Makefile38
1 files changed, 14 insertions, 24 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 245f5fb13fd4..04944196c74b 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -9,28 +9,25 @@ PORTNAME= netcdf
PORTVERSION= 3.6.3
PORTREVISION= 4
CATEGORIES= science
-MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
+MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
+ ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
http://sunpoet.net/distfiles/
MAINTAINER= sunpoet@sunpoet.net
COMMENT?= Library for machine-independent, array-oriented data access
CONFLICTS= hdf-4.* netcdf-4.*
+PORTSCOUT= limit:^3\.
CONFIGURE_ARGS= --enable-shared
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC ${FTNTYPE}"
-
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC"
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-#CONFIGURE_ENV+= ${MAKE_ENV}
-
-SLAVEDIRS= science/netcdf-ftn
-
-MAN1= ncdump.1 ncgen.1
-MAN3= netcdf.3
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
netcdf-install netcdf-tutorial
+MAN1= ncdump.1 ncgen.1
+MAN3= netcdf.3
OPTIONS= FORTRAN "Build library for Fortran" off
@@ -38,27 +35,20 @@ OPTIONS= FORTRAN "Build library for Fortran" off
CONFIGURE_ARGS+=--enable-docs-install
.else
CONFIGURE_ARGS+=--disable-docs-install
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-man-Makefile.in
-.endif
-
-.if !defined(NOPORTEXAMPLES)
-CONFIGURE_ARGS+=--enable-examples
-.else
-CONFIGURE_ARGS+=--disable-examples
.endif
.include <bsd.port.pre.mk>
.if defined(WITH_FORTRAN)
-USE_FORTRAN= yes
-PKGNAMESUFFIX+= -ftn
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -DpgiFortran"
CONFLICTS+= netcdf-3.*
MAN3+= netcdf_f77.3 netcdf_f90.3
+PKGNAMESUFFIX+= -ftn
PLIST_SUB+= FORTRAN=""
-FTNTYPE= -DpgiFortran
+USE_FORTRAN= yes
.else
+CONFIGURE_ARGS+=--disable-f77 --disable-f90
CONFLICTS+= netcdf-ftn-3.*
-CONFIGURE_ARGS+=--disable-f77
PLIST_SUB+= FORTRAN="@comment "
.endif
@@ -69,10 +59,10 @@ post-patch:
@${REINPLACE_CMD} -e \
'271 s/\(info_docs\).*/html_docs\)/' \
${WRKSRC}/man4/Makefile.in
-
-post-install:
- ${LN} -fs libnetcdf.so.4 ${PREFIX}/lib/libnetcdf.so
- ${LN} -fs libnetcdf_c++.so.4 ${PREFIX}/lib/libnetcdf_c++.so
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '790 s/install-docDATA //' \
+ ${WRKSRC}/man/Makefile.in
+.endif
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check