aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-29 03:40:22 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-29 03:40:22 +0000
commit479bf056d3f57c73be410c987e7ba4de45eb38f3 (patch)
treef8d85451f8fe3b4d9b539a34b0efd20658740e1f /science/netcdf/Makefile
parent84de868681c04d659868511db6b560d90f984e0d (diff)
downloadports-479bf056d3f57c73be410c987e7ba4de45eb38f3.tar.gz
ports-479bf056d3f57c73be410c987e7ba4de45eb38f3.zip
Update to version 3.5b3.
PR: 18748 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=28887
Diffstat (limited to 'science/netcdf/Makefile')
-rw-r--r--science/netcdf/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 3d74fe7fbcb2..17e5215399c9 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= netcdf
-PORTVERSION= 3.5b2
+PORTVERSION= 3.5b3
CATEGORIES= math
MASTER_SITES= ftp://unidata.ucar.edu/pub/netcdf/
-DISTFILES= netcdf-3.5-beta2.tar.Z
+DISTFILES= ${PORTNAME}-3.5-beta3.tar.Z
MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/netcdf-3.5/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-3.5-beta3/src
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC -DPIC -Df2cFortran"
+CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
MAN1= ncdump.1 ncgen.1
-MAN3= netcdf.3 netcdf.3f
+MAN3= netcdf.3
post-build:
@(cd ${WRKSRC}/libsrc && \
@@ -28,9 +28,9 @@ post-build:
post-install:
${INSTALL_DATA} ${WRKSRC}/libsrc/libnetcdf.so ${PREFIX}/lib/libnetcdf.so.1
- ${LN} -sf ${PREFIX}/lib/libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
+ ${LN} -sf libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
- ${LN} -sf ${PREFIX}/lib/libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ ${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
+ ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>