aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-05 06:00:34 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-05 06:00:34 +0000
commitf88ab0825767fd072cfced282445b15231d46e89 (patch)
treee0d53940041322bee9755ee64e1092d9211771ce /science/netcdf/Makefile
parent17eb3a679d61ae8e80f246ec4ce8825438f80235 (diff)
downloadports-f88ab0825767fd072cfced282445b15231d46e89.tar.gz
ports-f88ab0825767fd072cfced282445b15231d46e89.zip
BROKEN: Does not compile on 5.x
Notes
Notes: svn path=/head/; revision=100026
Diffstat (limited to 'science/netcdf/Makefile')
-rw-r--r--science/netcdf/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 13a6bf93e48d..1270af16e61c 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -24,6 +24,12 @@ INSTALLS_SHLIB= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-build:
@(cd ${WRKSRC}/libsrc && \
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
@@ -36,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>