aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf4
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-12 15:17:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-12 15:17:17 +0000
commit9eb8f07c0feb59c824defea7a88a6a4a4ad2b42f (patch)
tree7d9fe42a75c9fc9eb84a4c89802f75eb9cf7fbde /science/netcdf4
parentb5fae9520930489365b7dd9154ac75ef946e1459 (diff)
downloadports-9eb8f07c0feb59c824defea7a88a6a4a4ad2b42f.tar.gz
ports-9eb8f07c0feb59c824defea7a88a6a4a4ad2b42f.zip
Notes
Diffstat (limited to 'science/netcdf4')
-rw-r--r--science/netcdf4/Makefile50
-rw-r--r--science/netcdf4/distinfo5
-rw-r--r--science/netcdf4/pkg-plist4
3 files changed, 31 insertions, 28 deletions
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 9890cd6c4dd6..011c71eab2a9 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 4.1.1
+PORTVERSION= 4.1.2
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -21,10 +21,11 @@ PORTSCOUT= limit:^4\.
CONFIGURE_ARGS= --enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
--with-hdf5=${LOCALBASE} --with-zlib=/usr
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC"
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
GNU_CONFIGURE= yes
-LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
-MAKE_ENV+= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
+LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18
+MAKE_ENV= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
+USE_GNOME= gnomehack
USE_LDCONFIG= yes
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
@@ -32,19 +33,22 @@ INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
MAN1= nccopy.1 ncdump.1 ncgen.1 ncgen3.1
MAN3= netcdf.3
-OPTIONS= FORTRAN "Build library for Fortran" off \
+OPTIONS= DAP "Build DAP client and remote testing" off \
+ FORTRAN "Build library for Fortran" off \
SZIP "SZIP support (required if HDF5 was built with SZIP)" off
-.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+=--enable-docs-install
+.include <bsd.port.options.mk>
+
+.if defined(WITH_DAP)
+CONFIGURE_ARGS+=--enable-dap --with-curl=${LOCALBASE} \
+ --with-curl-config=${LOCALBASE}/bin/curl-config
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
.else
-CONFIGURE_ARGS+=--disable-docs-install
+CONFIGURE_ARGS+=--disable-dap
.endif
-.include <bsd.port.pre.mk>
-
.if defined(WITH_FORTRAN)
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -DpgiFortran"
+CPPFLAGS+= -DpgiFortran
CONFLICTS+= netcdf-4.*
MAN3+= netcdf_f77.3 netcdf_f90.3
PKGNAMESUFFIX+= -ftn
@@ -61,24 +65,24 @@ CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
.endif
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '297 s/\(info_docs\).*/html_docs\)/' \
- ${WRKSRC}/man4/Makefile.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '839 s/install-docDATA //' \
- ${WRKSRC}/man4/Makefile.in
-.endif
+#post-patch:
+# @${REINPLACE_CMD} -e \
+# 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
+# ${WRKSRC}/Makefile.in
post-configure:
- @cd ${WRKSRC}/man4 && make maintainer-clean-aminfo
+ @cd ${WRKSRC}/man4 && ${SETENV} ${MAKE_ENV} ${MAKE} maintainer-clean-aminfo
.for i in ${INFO}
@cd ${WRKSRC}/man4 && makeinfo --no-split ${i}.texi
.endfor
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/
+ @cd ${WRKSRC}/man4 && ${INSTALL_DATA} *.html *.info *.pdf *.ps *.txt ${DOCSDIR}/
+.endif
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/netcdf4/distinfo b/science/netcdf4/distinfo
index 5e4e824c4f98..8c2ea030c696 100644
--- a/science/netcdf4/distinfo
+++ b/science/netcdf4/distinfo
@@ -1,3 +1,2 @@
-MD5 (netcdf-4.1.1.tar.gz) = 79c5ff14c80d5e18dd8f1fceeae1c8e1
-SHA256 (netcdf-4.1.1.tar.gz) = 7933d69d378c57f038375bae4dd78c52442a06e2647fce4b75c13a225e342fb0
-SIZE (netcdf-4.1.1.tar.gz) = 11201096
+SHA256 (netcdf-4.1.2.tar.gz) = 0c8df55f5967be2cd6ede1a1e8a4a96a69d6b716ec649b3eba9640dbbcda16b9
+SIZE (netcdf-4.1.2.tar.gz) = 11021527
diff --git a/science/netcdf4/pkg-plist b/science/netcdf4/pkg-plist
index 7cb404202b33..54768c557f93 100644
--- a/science/netcdf4/pkg-plist
+++ b/science/netcdf4/pkg-plist
@@ -40,11 +40,11 @@ include/netcdfcpp.h
lib/libnetcdf.a
lib/libnetcdf.la
lib/libnetcdf.so
-lib/libnetcdf.so.6
+lib/libnetcdf.so.7
lib/libnetcdf_c++.a
lib/libnetcdf_c++.la
lib/libnetcdf_c++.so
-lib/libnetcdf_c++.so.5
+lib/libnetcdf_c++.so.4
lib/libnetcdf_c++4.a
lib/libnetcdf_c++4.la
lib/libnetcdf_c++4.so