aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf4
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /science/netcdf4
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
Notes
Diffstat (limited to 'science/netcdf4')
-rw-r--r--science/netcdf4/Makefile4
-rw-r--r--science/netcdf4/files/patch-cxx4-ncGroup.cpp29
2 files changed, 31 insertions, 2 deletions
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index ff905cbe209e..4ddc23522ec4 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netcdf
PORTVERSION= 4.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -52,7 +52,7 @@ CONFLICTS+= netcdf-4.*
MAN3+= netcdf_f77.3 netcdf_f90.3
PKGNAMESUFFIX+= -ftn
PLIST_SUB+= FORTRAN=""
-USE_FORTRAN= yes
+USES+= fortran
.else
CONFIGURE_ARGS+=--disable-f77 --disable-f90
CONFLICTS+= netcdf-ftn-4.*
diff --git a/science/netcdf4/files/patch-cxx4-ncGroup.cpp b/science/netcdf4/files/patch-cxx4-ncGroup.cpp
new file mode 100644
index 000000000000..bf0fc7d1bb05
--- /dev/null
+++ b/science/netcdf4/files/patch-cxx4-ncGroup.cpp
@@ -0,0 +1,29 @@
+--- cxx4/ncGroup.cpp.orig
++++ cxx4/ncGroup.cpp
+@@ -218,7 +218,7 @@
+
+ // search in child groups of the children
+ if(location == ChildrenOfChildrenGrps || location == AllChildrenGrps || location == AllGrps ) {
+- map<string,NcGroup>::iterator it;
++ multimap<string,NcGroup>::iterator it;
+ multimap<string,NcGroup> groups(getGroups(ChildrenGrps));
+ for (it=groups.begin();it!=groups.end();it++) {
+ multimap<string,NcGroup> childGroups(it->second.getGroups(AllChildrenGrps));
+@@ -1251,7 +1251,7 @@
+ // search in current group and parent groups.
+ NcGroup tmpGroup(*this);
+ multimap<string,NcDim>::iterator itD;
+- map<string,NcVar>::iterator itV;
++ multimap<string,NcVar>::iterator itV;
+ while(1) {
+ // get the collection of NcDim objects defined in this group.
+ multimap<string,NcDim> dimTmp(tmpGroup.getDims());
+@@ -1289,7 +1289,7 @@
+ // search in current group and parent groups.
+ multimap<string,NcDim>::iterator itD;
+ NcGroup tmpGroup(*this);
+- map<string,NcVar>::iterator itV;
++ multimap<string,NcVar>::iterator itV;
+ while(1) {
+ // get the collection of NcDim objects defined in this group.
+ multimap<string,NcDim> dimTmp(tmpGroup.getDims());