aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf4
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-09-26 15:11:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-09-26 15:11:38 +0000
commit18581ecd5684392ca58f1fe36e3547048e081c54 (patch)
tree3e44d7450523cea9f0a1ac3cabe04637d1c3990c /science/netcdf4
parent9afeaca11ba81cb4ca608564b1dd20ceb283c2a7 (diff)
downloadports-18581ecd5684392ca58f1fe36e3547048e081c54.tar.gz
ports-18581ecd5684392ca58f1fe36e3547048e081c54.zip
Notes
Diffstat (limited to 'science/netcdf4')
-rw-r--r--science/netcdf4/Makefile12
-rw-r--r--science/netcdf4/distinfo6
-rw-r--r--science/netcdf4/pkg-descr2
-rw-r--r--science/netcdf4/pkg-plist7
4 files changed, 16 insertions, 11 deletions
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 34a9ef8bb392..b417a782b278 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 4.0
+PORTVERSION= 4.0.1
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -19,8 +19,8 @@ CONFLICTS= hdf-4.* netcdf-3.*
LATEST_LINK= netcdf4
CONFIGURE_ARGS= --disable-f77 --disable-f90 \
- --enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
- --with-hdf5=${LOCALBASE} --with-zlib=/usr
+ --enable-cxx --enable-cxx-4 --enable-ncgen4 --enable-netcdf-4 \
+ --enable-shared --with-hdf5=${LOCALBASE} --with-zlib=/usr
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
MAKE_ENV+= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
@@ -32,7 +32,7 @@ LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
INFO= netcdf netcdf-c netcdf-cxx netcdf-cxx4 netcdf-f77 \
netcdf-f90 netcdf-install netcdf-tutorial
-MAN1= ncdump.1 ncgen.1
+MAN1= ncdump.1 ncgen.1 ncgen4.1
MAN3= netcdf.3
OPTIONS= HDF5_CONVERT "Do data conversion through HDF5" off
@@ -49,14 +49,14 @@ CONFIGURE_ARGS+=--enable-hdf5-convert
post-patch:
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '814 s/install-docDATA //' \
+ @${REINPLACE_CMD} -e '829 s/install-docDATA //' \
${WRKSRC}/man4/Makefile.in
.endif
@${REINPLACE_CMD} -e \
's/\(@INSTALL_DOCS_TRUE@MAN.*\)/# \1/' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
- '274 s/\(info_docs\).*/html_docs\)/' \
+ '288 s/\(info_docs\).*/html_docs\)/' \
${WRKSRC}/man4/Makefile.in
post-configure:
diff --git a/science/netcdf4/distinfo b/science/netcdf4/distinfo
index 953e56308e28..77b19bff2660 100644
--- a/science/netcdf4/distinfo
+++ b/science/netcdf4/distinfo
@@ -1,3 +1,3 @@
-MD5 (netcdf-4.0.tar.gz) = afc057b07b6e6843556dcfbc4ced402c
-SHA256 (netcdf-4.0.tar.gz) = 4f6934fd862b2e0f5a6ddcd8ef5f86a03d8aebfd106bc09c97afc80fe2ad5c96
-SIZE (netcdf-4.0.tar.gz) = 11584002
+MD5 (netcdf-4.0.1.tar.gz) = a251453c5477599f050fa4e593295186
+SHA256 (netcdf-4.0.1.tar.gz) = 290e377aa2e9419bb50a2fa1038d6e77d36f239a8a9c3be9e3a9319f1e484d19
+SIZE (netcdf-4.0.1.tar.gz) = 8018998
diff --git a/science/netcdf4/pkg-descr b/science/netcdf4/pkg-descr
index a8ab96607da6..fa18f64fac06 100644
--- a/science/netcdf4/pkg-descr
+++ b/science/netcdf4/pkg-descr
@@ -6,4 +6,4 @@ library, and format support the creation, access, and sharing of
scientific data. The netCDF software was developed at the Unidata
Program Center in Boulder, Colorado.
-WWW: http://www.unidata.ucar.edu/packages/netcdf/
+WWW: http://www.unidata.ucar.edu/software/netcdf/
diff --git a/science/netcdf4/pkg-plist b/science/netcdf4/pkg-plist
index c20aa2419771..5d1a3621254a 100644
--- a/science/netcdf4/pkg-plist
+++ b/science/netcdf4/pkg-plist
@@ -1,5 +1,7 @@
+bin/nc-config
bin/ncdump
bin/ncgen
+bin/ncgen4
include/ncvalues.h
include/netcdf.h
include/netcdf.hh
@@ -8,7 +10,7 @@ include/netcdfcpp4.h
lib/libnetcdf.a
lib/libnetcdf.la
lib/libnetcdf.so
-lib/libnetcdf.so.5
+lib/libnetcdf.so.6
lib/libnetcdf_c++.a
lib/libnetcdf_c++.la
lib/libnetcdf_c++.so
@@ -17,8 +19,10 @@ lib/libnetcdf_c++4.a
lib/libnetcdf_c++4.la
lib/libnetcdf_c++4.so
lib/libnetcdf_c++4.so.1
+lib/pkgconfig/netcdf.pc
%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
+%%PORTDOCS%%%%DOCSDIR%%/ncgen4-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps
@@ -55,3 +59,4 @@ lib/libnetcdf_c++4.so.1
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry lib/pkgconfig