aboutsummaryrefslogtreecommitdiff
path: root/science/nwchem
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-06 04:12:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-06 04:12:12 +0000
commitf7522939832cc598cbedc3bfda28aac3f3007463 (patch)
treef6c22dac025b7f5febe80f9be6bf10efa252565c /science/nwchem
parent8e85f0bd30b6cf46ec6bf8c24193711e5f8b8abc (diff)
downloadports-f7522939832cc598cbedc3bfda28aac3f3007463.tar.gz
ports-f7522939832cc598cbedc3bfda28aac3f3007463.zip
Notes
Diffstat (limited to 'science/nwchem')
-rw-r--r--science/nwchem/Makefile14
-rw-r--r--science/nwchem/files/patch-config_makefile.h8
-rw-r--r--science/nwchem/pkg-plist1
3 files changed, 14 insertions, 9 deletions
diff --git a/science/nwchem/Makefile b/science/nwchem/Makefile
index 0fe77e201bed..e991196f548c 100644
--- a/science/nwchem/Makefile
+++ b/science/nwchem/Makefile
@@ -2,8 +2,8 @@
PORTNAME= nwchem
DISTVERSION= 6.8.1-release-94
-PORTREVISION= 4
DISTVERSIONSUFFIX= -g1a262862b
+PORTREVISION= 5
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -35,7 +35,12 @@ MAKE_ENV= NWCHEM_TOP=${WRKSRC}/.. NWCHEM_MODULES=all NWCHEM_LONG_PATHS=Y NWCHEM_
SUB_FILES= nwchemrc
WRKSRC_SUBDIR= src
+
BINARY_ALIAS= gcc=${CC}
+MAKE_ARGS= LDFLAGS_FREEBSD="${LDFLAGS}"
+
+post-extract:
+ @${RM} ${WRKSRC}/atomscf/src.orig
post-patch:
@${REINPLACE_CMD} 's|nwchrc="/etc/nwchemrc"|nwchrc="${PREFIX}/etc/nwchemrc"|' ${WRKSRC}/util/util_nwchemrc.F
@@ -47,12 +52,7 @@ pre-build:
do-install:
${INSTALL_DATA} ${WRKDIR}/nwchemrc ${STAGEDIR}${PREFIX}/etc/nwchemrc
- ${INSTALL_PROGRAM} ${WRKSRC}/../bin/LINUX64/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.shadow
- @(echo "#!/bin/sh"; \
- echo ""; \
- echo "LD_PRELOAD=${PREFIX}/lib/gcc${GCC_DEFAULT}/libgcc_s.so ${PREFIX}/bin/${PORTNAME}.shadow \""$$"@\"" \
- ) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- @${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/LINUX64/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
cd ${WRKSRC}/basis && ${COPYTREE_SHARE} libraries ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/libraryps
diff --git a/science/nwchem/files/patch-config_makefile.h b/science/nwchem/files/patch-config_makefile.h
index 4113882588ac..5dce24620fc9 100644
--- a/science/nwchem/files/patch-config_makefile.h
+++ b/science/nwchem/files/patch-config_makefile.h
@@ -1,4 +1,4 @@
---- config/makefile.h.orig 2018-08-23 07:16:42 UTC
+--- config/makefile.h.orig 2018-10-01 05:39:33 UTC
+++ config/makefile.h
@@ -1758,9 +1758,9 @@ endif
ifeq ($(USE_FLANG),1)
@@ -12,3 +12,9 @@
GNU_GE_4_6 = $(shell [ $(GNUMAJOR) -gt 4 -o \( $(GNUMAJOR) -eq 4 -a $(GNUMINOR) -ge 6 \) ] && echo true)
GNU_GE_4_8 = $(shell [ $(GNUMAJOR) -gt 4 -o \( $(GNUMAJOR) -eq 4 -a $(GNUMINOR) -ge 8 \) ] && echo true)
endif
+@@ -2985,4 +2985,4 @@ endif
+
+ endif
+
+-
++LINK.f += $(LDFLAGS_FREEBSD) # ignores LDFLAGS: https://github.com/nwchemgit/nwchem/issues/64
diff --git a/science/nwchem/pkg-plist b/science/nwchem/pkg-plist
index 5d44454e0f07..b71ce644c5bd 100644
--- a/science/nwchem/pkg-plist
+++ b/science/nwchem/pkg-plist
@@ -1,5 +1,4 @@
bin/nwchem
-bin/nwchem.shadow
etc/nwchemrc
%%DATADIR%%/data/amber_q/ABE.frg
%%DATADIR%%/data/amber_q/BNZ.frg