aboutsummaryrefslogtreecommitdiff
path: root/science/octopus/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-06 00:22:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-06 00:22:45 +0000
commit78f4a2d9e206c6e957b3b26be334014b7a6cd8a7 (patch)
tree6b314b1cde507914cf77fa3ca3533bc9e794a67a /science/octopus/Makefile
parent29dc9791c3c1e58461fa757ad29ae08da40c51a1 (diff)
downloadports-78f4a2d9e206c6e957b3b26be334014b7a6cd8a7.tar.gz
ports-78f4a2d9e206c6e957b3b26be334014b7a6cd8a7.zip
Diffstat (limited to 'science/octopus/Makefile')
-rw-r--r--science/octopus/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/science/octopus/Makefile b/science/octopus/Makefile
index 08ab6559cba2..67b68df43580 100644
--- a/science/octopus/Makefile
+++ b/science/octopus/Makefile
@@ -1,6 +1,5 @@
PORTNAME= octopus
-DISTVERSION= 10.5
-PORTREVISION= 1
+DISTVERSION= 11.3
CATEGORIES= science
MASTER_SITES= https://octopus-code.org/download/${DISTVERSION}/
@@ -16,8 +15,10 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgd.so:graphics/gd \
+ libgmp.so:math/gmp \
libgsl.so:math/gsl \
liblapack.so:math/lapack \
+ libmpfr.so:math/mpfr \
libnlopt.so:math/nlopt \
libpng.so:graphics/png \
libsymspg.so:science/spglib \
@@ -27,15 +28,22 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libxc.so:science/libxc \
libyaml.so:textproc/libyaml
-USES= compiler:c++11-lang fortran gmake jpeg localbase:ldflags perl5 python shebangfix
+USES= compiler:c++11-lang fortran gmake jpeg libtool localbase:ldflags perl5 python shebangfix
+USE_CXXSTD= c++11
+USE_LDCONFIG= yes
+
SHEBANG_FILES= src/fdep/fortran_dependencies.pl testsuite/performance/create_combinations.py
+
GNU_CONFIGURE= yes
CONFIGURE_SHELL= ${PREFIX}/bin/bash
-USE_CXXSTD= c++11
+CONFIGURE_ARGS= --enable-shared --disable-static
LDFLAGS+= -lsymspg
FCFLAGS+= -I${LOCALBASE}/include -ffree-line-length-none
+INSTALL_TARGET= install-strip
+TEST_TARGET= check-short # tests fail: https://gitlab.com/octopus-code/octopus/-/issues/536
+
OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
OPENMP_CONFIGURE_ENABLE= openmp