aboutsummaryrefslogtreecommitdiff
path: root/science/openbabel/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-18 10:37:25 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-18 10:37:25 +0000
commit7b0a4beb5cfbd098e64088b0788af96bb8a24a6d (patch)
treeb9bee2e88b1db6f9d1bdad0c0b407403b007fd83 /science/openbabel/Makefile
parentb1884f396facd7c52f9ac92dd5e08351a34c2b48 (diff)
downloadports-7b0a4beb5cfbd098e64088b0788af96bb8a24a6d.tar.gz
ports-7b0a4beb5cfbd098e64088b0788af96bb8a24a6d.zip
Notes
Diffstat (limited to 'science/openbabel/Makefile')
-rw-r--r--science/openbabel/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index f07fefabec35..bf111c6b704e 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= openbabel
-PORTVERSION= 1.100.2
+PORTVERSION= 2.0.0
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,12 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Chemistry file translation program
+USE_GCC= 3.4+
+USE_GNOME= gnomehack gnometarget libxml2
USE_AUTOTOOLS= libtool:15
-USE_GNOME= gnomehack gnometarget pkgconfig
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=open
INSTALLS_SHLIB= yes
-MAN1= openbabel.1
+MAN1= obchiral.1 obfit.1 obgrep.1 obprop.1 obrotate.1 openbabel.1
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+post-extract:
+ @${LN} -sf babel.1 ${WRKSRC}/doc/openbabel.1
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|= babel|= openbabel|g' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's| babel| openbabel|g ; \
+ s|"babel|"openbabel|g' ${WRKSRC}/doc/o*.1
+ @${REINPLACE_CMD} -e 's|^babel|openbabel|g ; \
+ s|(babel|(openbabel|g ; \
+ s|= babel|= openbabel|g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>