aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Chemistry-Reaction
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:32:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:32:03 +0000
commit0c0fc43cf87e32b10148348e6016adad4a8a5d7f (patch)
treefe508809f8a7ef173faa7722dc90ec4f679a13f5 /science/p5-Chemistry-Reaction
parente686fdf65d38ba2b8b307acb6b5780e4453e4d75 (diff)
downloadports-0c0fc43cf87e32b10148348e6016adad4a8a5d7f.tar.gz
ports-0c0fc43cf87e32b10148348e6016adad4a8a5d7f.zip
Notes
Diffstat (limited to 'science/p5-Chemistry-Reaction')
-rw-r--r--science/p5-Chemistry-Reaction/Makefile31
-rw-r--r--science/p5-Chemistry-Reaction/distinfo3
-rw-r--r--science/p5-Chemistry-Reaction/pkg-descr3
-rw-r--r--science/p5-Chemistry-Reaction/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/science/p5-Chemistry-Reaction/Makefile b/science/p5-Chemistry-Reaction/Makefile
new file mode 100644
index 000000000000..03ee9721f5e5
--- /dev/null
+++ b/science/p5-Chemistry-Reaction/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Chemistry-Reaction
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Reaction
+PORTVERSION= 0.02
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Represent a ring as a substructure of a molecule
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern
+
+MAN3= Chemistry::Reaction.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Reaction/distinfo b/science/p5-Chemistry-Reaction/distinfo
new file mode 100644
index 000000000000..80bbc8bc6d88
--- /dev/null
+++ b/science/p5-Chemistry-Reaction/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Reaction-0.02.tar.gz) = 3be515bac03f21c6b0d0001a417139ab
+SHA256 (Chemistry-Reaction-0.02.tar.gz) = ad7a05608f5bbbd0f7c80a67027931539512382d393038aec4fb071d4939492a
+SIZE (Chemistry-Reaction-0.02.tar.gz) = 5358
diff --git a/science/p5-Chemistry-Reaction/pkg-descr b/science/p5-Chemistry-Reaction/pkg-descr
new file mode 100644
index 000000000000..59c0905577d9
--- /dev/null
+++ b/science/p5-Chemistry-Reaction/pkg-descr
@@ -0,0 +1,3 @@
+Explicit chemical reactions
+
+WWW: http://search.cpan.org/dist/Chemistry-Raction/
diff --git a/science/p5-Chemistry-Reaction/pkg-plist b/science/p5-Chemistry-Reaction/pkg-plist
new file mode 100644
index 000000000000..aabe62a95dca
--- /dev/null
+++ b/science/p5-Chemistry-Reaction/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Chemistry/Reaction.pm
+%%SITE_PERL%%/mach/auto/Chemistry/Reaction/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Reaction
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry