aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Geo-BUFR
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-10 06:15:55 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-10 06:15:55 +0000
commitca7b73fa1749920d24bd4c0bfc3cb104751c6588 (patch)
tree9ebccd0169a5af3746fdb76e9d95863253f581fc /science/p5-Geo-BUFR
parent5c9a951d71adc394e5c740adf5c5bff5ba670ac6 (diff)
downloadports-ca7b73fa1749920d24bd4c0bfc3cb104751c6588.tar.gz
ports-ca7b73fa1749920d24bd4c0bfc3cb104751c6588.zip
Notes
Diffstat (limited to 'science/p5-Geo-BUFR')
-rw-r--r--science/p5-Geo-BUFR/Makefile34
-rw-r--r--science/p5-Geo-BUFR/distinfo2
-rw-r--r--science/p5-Geo-BUFR/pkg-descr16
-rw-r--r--science/p5-Geo-BUFR/pkg-plist17
4 files changed, 69 insertions, 0 deletions
diff --git a/science/p5-Geo-BUFR/Makefile b/science/p5-Geo-BUFR/Makefile
new file mode 100644
index 000000000000..51c856331a8d
--- /dev/null
+++ b/science/p5-Geo-BUFR/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Geo-BUFR
+# Date created: March 10, 2011
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-BUFR
+PORTVERSION= 1.20
+CATEGORIES= science perl5 geography
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PSANNES
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl extension for handling of WMO BUFR files
+
+RUN_DEPENDS= p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp
+
+MAN1= bufr_reencode.pl.1 \
+ bufralter.pl.1 \
+ bufrencode.pl.1 \
+ bufrread.pl.1 \
+ bufrresolve.pl.1
+MAN3= Geo::BUFR.3 \
+ Geo::bufrresolve.3 \
+ Geo::bufr_reencode.3 \
+ Geo::bufrread.3 \
+ Geo::bufralter.3 \
+ Geo::bufrencode.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Geo-BUFR/distinfo b/science/p5-Geo-BUFR/distinfo
new file mode 100644
index 000000000000..53f7af39d217
--- /dev/null
+++ b/science/p5-Geo-BUFR/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-BUFR-1.20.tar.gz) = 281e45fd8f308c4019e6c48b4e09f2f2c2973690d389f5bfe40f727494e0b3d0
+SIZE (Geo-BUFR-1.20.tar.gz) = 248606
diff --git a/science/p5-Geo-BUFR/pkg-descr b/science/p5-Geo-BUFR/pkg-descr
new file mode 100644
index 000000000000..f08b9105d047
--- /dev/null
+++ b/science/p5-Geo-BUFR/pkg-descr
@@ -0,0 +1,16 @@
+BUFR = Binary Universal Form for the Representation of meteorological data.
+BUFR is approved by WMO (World Meteorological Organization) as the standard
+universal exchange format for meteorological observations, gradually
+replacing a lot of older alphanumeric data formats.
+
+This module provides methods for decoding and encoding BUFR messages, and
+for displaying information in BUFR B and D tables and in BUFR flag and code
+tables.
+
+Installing this module also installs some programs: bufrread.pl,
+bufrresolve.pl, bufrencode.pl, bufr_reencode.pl and bufralter.pl. See
+https://wiki.met.no/bufr.pm/start for examples of use. For the majority of
+potential users of Geo::BUFR I would expect these programs to be all that
+you will need Geo::BUFR for.
+
+WWW: http://search.cpan.org/dist/Geo-BUFR/
diff --git a/science/p5-Geo-BUFR/pkg-plist b/science/p5-Geo-BUFR/pkg-plist
new file mode 100644
index 000000000000..27b903b5b3b5
--- /dev/null
+++ b/science/p5-Geo-BUFR/pkg-plist
@@ -0,0 +1,17 @@
+bin/bufr_reencode.pl
+bin/bufralter.pl
+bin/bufrencode.pl
+bin/bufrread.pl
+bin/bufrresolve.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/BUFR/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/BUFR/BUFR.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/BUFR/BUFR.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/BUFR.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/bufrresolve.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/bufralter.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/bufr_reencode.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/bufrread.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Geo/bufrencode.pl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/BUFR
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Geo