aboutsummaryrefslogtreecommitdiff
path: root/science/p5-PerlMol/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:36:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:36:26 +0000
commit83e3ba00ba042aa1a47da802e2113e97ef18b850 (patch)
tree11fc30647272349fac6a0c98005921a84e8c9606 /science/p5-PerlMol/Makefile
parenta6af1d634fea23d1f0cdef58f7510437e7108c6a (diff)
Notes
Diffstat (limited to 'science/p5-PerlMol/Makefile')
-rw-r--r--science/p5-PerlMol/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/science/p5-PerlMol/Makefile b/science/p5-PerlMol/Makefile
new file mode 100644
index 000000000000..1e5216b366b6
--- /dev/null
+++ b/science/p5-PerlMol/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: p5-PerlMol
+# Date created: 2010-03-04
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PerlMol
+PORTVERSION= 0.3500
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Perl modules for molecular chemistry
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/MacroMol.pm:${PORTSDIR}/science/p5-Chemistry-MacroMol \
+ ${SITE_PERL}/Parse/Yapp/Parse.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Chemistry/File/SMARTS.pm:${PORTSDIR}/science/p5-Chemistry-File-SMARTS \
+ ${SITE_PERL}/Chemistry/InternalCoords.pm:${PORTSDIR}/science/p5-Chemistry-InternalCoords \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern \
+ ${SITE_PERL}/Chemistry/Ring.pm:${PORTSDIR}/science/p5-Chemistry-Ring \
+ ${SITE_PERL}/Chemistry/Isotope.pm:${PORTSDIR}/science/p5-Chemistry-Isotope \
+ ${SITE_PERL}/Chemistry/3DBuilder.pm:${PORTSDIR}/science/p5-Chemistry-3DBuilder \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize \
+ ${SITE_PERL}/Chemistry/File/PDB.pm:${PORTSDIR}/science/p5-Chemistry-File-PDB \
+ ${SITE_PERL}/Chemistry/File/XYZ.pm:${PORTSDIR}/science/p5-Chemistry-File-XYZ \
+ ${SITE_PERL}/Chemistry/File/VRML.pm:${PORTSDIR}/science/p5-Chemistry-File-VRML \
+ ${SITE_PERL}/Chemistry/File/SLN.pm:${PORTSDIR}/science/p5-Chemistry-File-SLN \
+ ${SITE_PERL}/Chemistry/File/Mopac.pm:${PORTSDIR}/science/p5-Chemistry-File-Mopac \
+ ${SITE_PERL}/Chemistry/File/MDLMol.pm:${PORTSDIR}/science/p5-Chemistry-File-MDLMol \
+ ${SITE_PERL}/Chemistry/Reaction.pm:${PORTSDIR}/science/p5-Chemistry-Reaction \
+ ${SITE_PERL}/Chemistry/FormulaPattern.pm:${PORTSDIR}/science/p5-Chemistry-FormulaPattern \
+ ${SITE_PERL}/Chemistry/MidasPattern.pm:${PORTSDIR}/science/p5-Chemistry-MidasPattern \
+ ${SITE_PERL}/Chemistry/Mok.pm:${PORTSDIR}/science/p5-Chemistry-Mok \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/MacroMol.pm:${PORTSDIR}/science/p5-Chemistry-MacroMol \
+ ${SITE_PERL}/Parse/Yapp/Parse.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Chemistry/File/SMARTS.pm:${PORTSDIR}/science/p5-Chemistry-File-SMARTS \
+ ${SITE_PERL}/Chemistry/InternalCoords.pm:${PORTSDIR}/science/p5-Chemistry-InternalCoords \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern \
+ ${SITE_PERL}/Chemistry/Ring.pm:${PORTSDIR}/science/p5-Chemistry-Ring \
+ ${SITE_PERL}/Chemistry/Isotope.pm:${PORTSDIR}/science/p5-Chemistry-Isotope \
+ ${SITE_PERL}/Chemistry/3DBuilder.pm:${PORTSDIR}/science/p5-Chemistry-3DBuilder \
+ ${SITE_PERL}/Chemistry/Bond/Find.pm:${PORTSDIR}/science/p5-Chemistry-Bond-Find \
+ ${SITE_PERL}/Chemistry/Canonicalize.pm:${PORTSDIR}/science/p5-Chemistry-Canonicalize \
+ ${SITE_PERL}/Chemistry/File/PDB.pm:${PORTSDIR}/science/p5-Chemistry-File-PDB \
+ ${SITE_PERL}/Chemistry/File/XYZ.pm:${PORTSDIR}/science/p5-Chemistry-File-XYZ \
+ ${SITE_PERL}/Chemistry/File/VRML.pm:${PORTSDIR}/science/p5-Chemistry-File-VRML \
+ ${SITE_PERL}/Chemistry/File/SLN.pm:${PORTSDIR}/science/p5-Chemistry-File-SLN \
+ ${SITE_PERL}/Chemistry/File/Mopac.pm:${PORTSDIR}/science/p5-Chemistry-File-Mopac \
+ ${SITE_PERL}/Chemistry/File/MDLMol.pm:${PORTSDIR}/science/p5-Chemistry-File-MDLMol \
+ ${SITE_PERL}/Chemistry/Reaction.pm:${PORTSDIR}/science/p5-Chemistry-Reaction \
+ ${SITE_PERL}/Chemistry/FormulaPattern.pm:${PORTSDIR}/science/p5-Chemistry-FormulaPattern \
+ ${SITE_PERL}/Chemistry/MidasPattern.pm:${PORTSDIR}/science/p5-Chemistry-MidasPattern \
+ ${SITE_PERL}/Chemistry/Mok.pm:${PORTSDIR}/science/p5-Chemistry-Mok \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression
+
+PERL_CONFIGURE= yes
+
+MAN3= PerlMol.3
+
+.include <bsd.port.mk>