aboutsummaryrefslogtreecommitdiff
path: root/science/pagmo2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-01 07:16:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-01 07:16:57 +0000
commit7346f80c67b8e5855680033c8ffee6edafbe2adc (patch)
treee84e579c2350bb5f05c7157be4a7ce569017371d /science/pagmo2
parentde7365df7c2e581e50d6b61813cb534c2fb0d416 (diff)
downloadports-7346f80c67b8e5855680033c8ffee6edafbe2adc.tar.gz
ports-7346f80c67b8e5855680033c8ffee6edafbe2adc.zip
Notes
Diffstat (limited to 'science/pagmo2')
-rw-r--r--science/pagmo2/Makefile39
-rw-r--r--science/pagmo2/distinfo3
-rw-r--r--science/pagmo2/pkg-descr6
-rw-r--r--science/pagmo2/pkg-plist167
4 files changed, 215 insertions, 0 deletions
diff --git a/science/pagmo2/Makefile b/science/pagmo2/Makefile
new file mode 100644
index 000000000000..d171d3523e22
--- /dev/null
+++ b/science/pagmo2/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= pagmo2
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.10-161
+DISTVERSIONSUFFIX= -g0a589425
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Platform to perform parallel computations of optimization tasks
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING.gpl3
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.lgpl3
+
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
+ Ipopt>0:math/ipopt \
+ nlopt>0:math/nlopt
+RUN_DEPENDS= boost-libs>0:devel/boost-libs \
+ Ipopt>0:math/ipopt \
+ nlopt>0:math/nlopt
+
+USES= cmake eigen:3,build,run
+USE_GITHUB= yes
+GH_ACCOUNT= esa
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+CMAKE_ON= PAGMO_WITH_EIGEN3 PAGMO_WITH_NLOPT PAGMO_WITH_IPOPT
+
+do-test: # tests fail to build: https://github.com/esa/pagmo2/issues/273
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DPAGMO_BUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/science/pagmo2/distinfo b/science/pagmo2/distinfo
new file mode 100644
index 000000000000..83a3290ccd3a
--- /dev/null
+++ b/science/pagmo2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556692823
+SHA256 (esa-pagmo2-v2.10-161-g0a589425_GH0.tar.gz) = 947f11d7b09fcf9b88be1e3913d727eefb2c2e7dcb1d81f3bfa45d61ca7c3bd6
+SIZE (esa-pagmo2-v2.10-161-g0a589425_GH0.tar.gz) = 17709599
diff --git a/science/pagmo2/pkg-descr b/science/pagmo2/pkg-descr
new file mode 100644
index 000000000000..4478207076f6
--- /dev/null
+++ b/science/pagmo2/pkg-descr
@@ -0,0 +1,6 @@
+pagmo (C++) is a scientific library for massively parallel optimization. It is
+built around the idea of providing a unified interface to optimization
+algorithms and to optimization problems and to make their deployment in
+massively parallel environments easy.
+
+WWW: https://github.com/esa/pagmo2
diff --git a/science/pagmo2/pkg-plist b/science/pagmo2/pkg-plist
new file mode 100644
index 000000000000..ba69d05bcb49
--- /dev/null
+++ b/science/pagmo2/pkg-plist
@@ -0,0 +1,167 @@
+include/pagmo/algorithm.hpp
+include/pagmo/algorithms/bee_colony.hpp
+include/pagmo/algorithms/cmaes.hpp
+include/pagmo/algorithms/compass_search.hpp
+include/pagmo/algorithms/cstrs_self_adaptive.hpp
+include/pagmo/algorithms/de.hpp
+include/pagmo/algorithms/de1220.hpp
+include/pagmo/algorithms/gaco.hpp
+include/pagmo/algorithms/gwo.hpp
+include/pagmo/algorithms/ihs.hpp
+include/pagmo/algorithms/ipopt.hpp
+include/pagmo/algorithms/mbh.hpp
+include/pagmo/algorithms/moead.hpp
+include/pagmo/algorithms/nlopt.hpp
+include/pagmo/algorithms/not_population_based.hpp
+include/pagmo/algorithms/nsga2.hpp
+include/pagmo/algorithms/pso.hpp
+include/pagmo/algorithms/pso_gen.hpp
+include/pagmo/algorithms/sade.hpp
+include/pagmo/algorithms/sea.hpp
+include/pagmo/algorithms/sga.hpp
+include/pagmo/algorithms/simulated_annealing.hpp
+include/pagmo/algorithms/xnes.hpp
+include/pagmo/archipelago.hpp
+include/pagmo/config.hpp
+include/pagmo/detail/cec2013_data.hpp
+include/pagmo/detail/cec2014_data.hpp
+include/pagmo/detail/constants.hpp
+include/pagmo/detail/custom_comparisons.hpp
+include/pagmo/detail/eigen.hpp
+include/pagmo/detail/make_unique.hpp
+include/pagmo/detail/prime_numbers.hpp
+include/pagmo/detail/task_queue.hpp
+include/pagmo/exceptions.hpp
+include/pagmo/external/cereal/access.hpp
+include/pagmo/external/cereal/archives/adapters.hpp
+include/pagmo/external/cereal/archives/binary.hpp
+include/pagmo/external/cereal/archives/json.hpp
+include/pagmo/external/cereal/archives/portable_binary.hpp
+include/pagmo/external/cereal/archives/xml.hpp
+include/pagmo/external/cereal/cereal.hpp
+include/pagmo/external/cereal/details/helpers.hpp
+include/pagmo/external/cereal/details/polymorphic_impl.hpp
+include/pagmo/external/cereal/details/polymorphic_impl_fwd.hpp
+include/pagmo/external/cereal/details/static_object.hpp
+include/pagmo/external/cereal/details/traits.hpp
+include/pagmo/external/cereal/details/util.hpp
+include/pagmo/external/cereal/external/base64.hpp
+include/pagmo/external/cereal/external/rapidjson/allocators.h
+include/pagmo/external/cereal/external/rapidjson/document.h
+include/pagmo/external/cereal/external/rapidjson/encodedstream.h
+include/pagmo/external/cereal/external/rapidjson/encodings.h
+include/pagmo/external/cereal/external/rapidjson/error/en.h
+include/pagmo/external/cereal/external/rapidjson/error/error.h
+include/pagmo/external/cereal/external/rapidjson/filereadstream.h
+include/pagmo/external/cereal/external/rapidjson/filewritestream.h
+include/pagmo/external/cereal/external/rapidjson/fwd.h
+include/pagmo/external/cereal/external/rapidjson/internal/biginteger.h
+include/pagmo/external/cereal/external/rapidjson/internal/diyfp.h
+include/pagmo/external/cereal/external/rapidjson/internal/dtoa.h
+include/pagmo/external/cereal/external/rapidjson/internal/ieee754.h
+include/pagmo/external/cereal/external/rapidjson/internal/itoa.h
+include/pagmo/external/cereal/external/rapidjson/internal/meta.h
+include/pagmo/external/cereal/external/rapidjson/internal/pow10.h
+include/pagmo/external/cereal/external/rapidjson/internal/regex.h
+include/pagmo/external/cereal/external/rapidjson/internal/stack.h
+include/pagmo/external/cereal/external/rapidjson/internal/strfunc.h
+include/pagmo/external/cereal/external/rapidjson/internal/strtod.h
+include/pagmo/external/cereal/external/rapidjson/internal/swap.h
+include/pagmo/external/cereal/external/rapidjson/istreamwrapper.h
+include/pagmo/external/cereal/external/rapidjson/memorybuffer.h
+include/pagmo/external/cereal/external/rapidjson/memorystream.h
+include/pagmo/external/cereal/external/rapidjson/msinttypes/inttypes.h
+include/pagmo/external/cereal/external/rapidjson/msinttypes/stdint.h
+include/pagmo/external/cereal/external/rapidjson/ostreamwrapper.h
+include/pagmo/external/cereal/external/rapidjson/pointer.h
+include/pagmo/external/cereal/external/rapidjson/prettywriter.h
+include/pagmo/external/cereal/external/rapidjson/rapidjson.h
+include/pagmo/external/cereal/external/rapidjson/reader.h
+include/pagmo/external/cereal/external/rapidjson/schema.h
+include/pagmo/external/cereal/external/rapidjson/stream.h
+include/pagmo/external/cereal/external/rapidjson/stringbuffer.h
+include/pagmo/external/cereal/external/rapidjson/writer.h
+include/pagmo/external/cereal/external/rapidxml/license.txt
+include/pagmo/external/cereal/external/rapidxml/manual.html
+include/pagmo/external/cereal/external/rapidxml/rapidxml.hpp
+include/pagmo/external/cereal/external/rapidxml/rapidxml_iterators.hpp
+include/pagmo/external/cereal/external/rapidxml/rapidxml_print.hpp
+include/pagmo/external/cereal/external/rapidxml/rapidxml_utils.hpp
+include/pagmo/external/cereal/macros.hpp
+include/pagmo/external/cereal/types/array.hpp
+include/pagmo/external/cereal/types/base_class.hpp
+include/pagmo/external/cereal/types/bitset.hpp
+include/pagmo/external/cereal/types/boost_variant.hpp
+include/pagmo/external/cereal/types/chrono.hpp
+include/pagmo/external/cereal/types/common.hpp
+include/pagmo/external/cereal/types/complex.hpp
+include/pagmo/external/cereal/types/concepts/pair_associative_container.hpp
+include/pagmo/external/cereal/types/deque.hpp
+include/pagmo/external/cereal/types/forward_list.hpp
+include/pagmo/external/cereal/types/functional.hpp
+include/pagmo/external/cereal/types/list.hpp
+include/pagmo/external/cereal/types/map.hpp
+include/pagmo/external/cereal/types/memory.hpp
+include/pagmo/external/cereal/types/polymorphic.hpp
+include/pagmo/external/cereal/types/queue.hpp
+include/pagmo/external/cereal/types/set.hpp
+include/pagmo/external/cereal/types/stack.hpp
+include/pagmo/external/cereal/types/string.hpp
+include/pagmo/external/cereal/types/tuple.hpp
+include/pagmo/external/cereal/types/unordered_map.hpp
+include/pagmo/external/cereal/types/unordered_set.hpp
+include/pagmo/external/cereal/types/utility.hpp
+include/pagmo/external/cereal/types/valarray.hpp
+include/pagmo/external/cereal/types/vector.hpp
+include/pagmo/external/fix_includes.txt
+include/pagmo/io.hpp
+include/pagmo/island.hpp
+include/pagmo/islands/fork_island.hpp
+include/pagmo/islands/thread_island.hpp
+include/pagmo/pagmo.hpp
+include/pagmo/population.hpp
+include/pagmo/problem.hpp
+include/pagmo/problems/ackley.hpp
+include/pagmo/problems/cec2006.hpp
+include/pagmo/problems/cec2009.hpp
+include/pagmo/problems/cec2013.hpp
+include/pagmo/problems/cec2014.hpp
+include/pagmo/problems/decompose.hpp
+include/pagmo/problems/dtlz.hpp
+include/pagmo/problems/golomb_ruler.hpp
+include/pagmo/problems/griewank.hpp
+include/pagmo/problems/hock_schittkowsky_71.hpp
+include/pagmo/problems/inventory.hpp
+include/pagmo/problems/lennard_jones.hpp
+include/pagmo/problems/luksan_vlcek1.hpp
+include/pagmo/problems/minlp_rastrigin.hpp
+include/pagmo/problems/rastrigin.hpp
+include/pagmo/problems/rosenbrock.hpp
+include/pagmo/problems/schwefel.hpp
+include/pagmo/problems/translate.hpp
+include/pagmo/problems/unconstrain.hpp
+include/pagmo/problems/zdt.hpp
+include/pagmo/rng.hpp
+include/pagmo/serialization.hpp
+include/pagmo/threading.hpp
+include/pagmo/type_traits.hpp
+include/pagmo/types.hpp
+include/pagmo/utils/constrained.hpp
+include/pagmo/utils/discrepancy.hpp
+include/pagmo/utils/generic.hpp
+include/pagmo/utils/gradients_and_hessians.hpp
+include/pagmo/utils/hv_algos/hv_algorithm.hpp
+include/pagmo/utils/hv_algos/hv_bf_approx.hpp
+include/pagmo/utils/hv_algos/hv_bf_fpras.hpp
+include/pagmo/utils/hv_algos/hv_hv2d.hpp
+include/pagmo/utils/hv_algos/hv_hv3d.hpp
+include/pagmo/utils/hv_algos/hv_hvwfg.hpp
+include/pagmo/utils/hypervolume.hpp
+include/pagmo/utils/multi_objective.hpp
+lib/cmake/pagmo/FindEigen3.cmake
+lib/cmake/pagmo/FindIPOPT.cmake
+lib/cmake/pagmo/FindNLOPT.cmake
+lib/cmake/pagmo/PagmoFindBoost.cmake
+lib/cmake/pagmo/pagmo-config-version.cmake
+lib/cmake/pagmo/pagmo-config.cmake
+lib/cmake/pagmo/pagmo_export.cmake