aboutsummaryrefslogtreecommitdiff
path: root/science/pcp
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:34:54 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:34:54 +0000
commite8011a85cdf5cc30afcb0f8dd71e3040b0d09498 (patch)
treeae976b8f14abc86d2c8ab72965be40d82fb05286 /science/pcp
parent09c4ec343e5b9251d726a64a175af0fc5cf91dfa (diff)
downloadports-e8011a85cdf5cc30afcb0f8dd71e3040b0d09498.tar.gz
ports-e8011a85cdf5cc30afcb0f8dd71e3040b0d09498.zip
Notes
Diffstat (limited to 'science/pcp')
-rw-r--r--science/pcp/Makefile19
-rw-r--r--science/pcp/distinfo3
-rw-r--r--science/pcp/pkg-descr21
-rw-r--r--science/pcp/pkg-plist2
4 files changed, 45 insertions, 0 deletions
diff --git a/science/pcp/Makefile b/science/pcp/Makefile
new file mode 100644
index 000000000000..94ca605bbb55
--- /dev/null
+++ b/science/pcp/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: pcp
+# Date created: 2006-07-25
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcp
+PORTVERSION= 2.2
+CATEGORIES= science math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Machine learning program for pattern classification
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/pcp/distinfo b/science/pcp/distinfo
new file mode 100644
index 000000000000..7aafd527a17d
--- /dev/null
+++ b/science/pcp/distinfo
@@ -0,0 +1,3 @@
+MD5 (pcp-2.2.tar.gz) = 5be1ace0dbcd07dab47302807fa32c39
+SHA256 (pcp-2.2.tar.gz) = 928f2b7ea40de8ad5568f381a77b9379907a4966a56352cf5945a8664258d95a
+SIZE (pcp-2.2.tar.gz) = 2710238
diff --git a/science/pcp/pkg-descr b/science/pcp/pkg-descr
new file mode 100644
index 000000000000..bdb2a46f51cf
--- /dev/null
+++ b/science/pcp/pkg-descr
@@ -0,0 +1,21 @@
+PCP (Pattern Classification Program) is an open-source
+machine learning program for supervised classification
+of patterns (vectors of measurements).
+
+PCP implements the following algorithms and methods:
+
+* Fisher's linear discriminant
+* dimensionality reduction using Singular Value Decomposition
+* Principal Component Analysis
+* feature subset selection
+* Bayes error estimation
+* parametric classifiers (linear and quadratic)
+* least-squares (pseudo-inverse) linear discriminant
+* k-Nearest Neighbor (k-NN)
+* neural networks (Multi-Layer Perceptron (MLP))
+* Support Vector Machine (SVM) algorithm
+* SVM, MLP and k-NN model selection
+* cross-validation
+* bagging (committee) classification
+
+WWW: http://pcp.sourceforge.net/
diff --git a/science/pcp/pkg-plist b/science/pcp/pkg-plist
new file mode 100644
index 000000000000..6e125b8814c7
--- /dev/null
+++ b/science/pcp/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/pcp