aboutsummaryrefslogtreecommitdiff
path: root/science/peekabot
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-22 15:55:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-22 15:55:11 +0000
commita1c37dd174f8731fbc17129d507d0c0a2f84a5d3 (patch)
tree7f5d20baa4f89dfb2781cc05452a33ddd632ba66 /science/peekabot
parent0774e0738297da9d30059c9ec3f77e6f35c16945 (diff)
downloadports-a1c37dd174f8731fbc17129d507d0c0a2f84a5d3.tar.gz
ports-a1c37dd174f8731fbc17129d507d0c0a2f84a5d3.zip
Notes
Diffstat (limited to 'science/peekabot')
-rw-r--r--science/peekabot/Makefile28
-rw-r--r--science/peekabot/distinfo3
-rw-r--r--science/peekabot/files/patch-src-3rdparty-png++-config.hpp14
-rw-r--r--science/peekabot/pkg-descr9
-rw-r--r--science/peekabot/pkg-plist111
5 files changed, 165 insertions, 0 deletions
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
new file mode 100644
index 000000000000..e578c829ff49
--- /dev/null
+++ b/science/peekabot/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: peekabot
+# Date created: 21 June 2009
+# Whom: chris@officialunix.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= peekabot
+PORTVERSION= 0.6.0
+CATEGORIES= science
+MASTER_SITES= SF
+
+MAINTAINER= chris@officialunix.com
+COMMENT= Distributed real-time 3D visualization tool for robotics researchers
+
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost \
+ xerces-c.27:${PORTSDIR}/textproc/xerces-c2\
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GCC= 4.2+
+
+.include <bsd.port.mk>
diff --git a/science/peekabot/distinfo b/science/peekabot/distinfo
new file mode 100644
index 000000000000..6278e1ef345a
--- /dev/null
+++ b/science/peekabot/distinfo
@@ -0,0 +1,3 @@
+MD5 (peekabot-0.6.0.tar.bz2) = 9de6f733272516aea9ed27842055eee3
+SHA256 (peekabot-0.6.0.tar.bz2) = 4bc2218985ce474ef34692c1e576c762a8b68a85c080395473119dfcae4aa67e
+SIZE (peekabot-0.6.0.tar.bz2) = 2568809
diff --git a/science/peekabot/files/patch-src-3rdparty-png++-config.hpp b/science/peekabot/files/patch-src-3rdparty-png++-config.hpp
new file mode 100644
index 000000000000..b4c56c603758
--- /dev/null
+++ b/science/peekabot/files/patch-src-3rdparty-png++-config.hpp
@@ -0,0 +1,14 @@
+--- src/3rdparty/png++/config.hpp.orig 2009-06-15 02:57:01.000000000 +0400
++++ src/3rdparty/png++/config.hpp 2009-06-22 02:47:55.000000000 +0400
+@@ -47,6 +47,11 @@
+ #include <machine/endian.h>
+ #include <sys/_endian.h>
+
++#elif defined(__FreeBSD__)
++
++#include <machine/endian.h>
++#include <sys/endian.h>
++
+ #else
+
+ #error Byte-order could not be detected.
diff --git a/science/peekabot/pkg-descr b/science/peekabot/pkg-descr
new file mode 100644
index 000000000000..688511b45064
--- /dev/null
+++ b/science/peekabot/pkg-descr
@@ -0,0 +1,9 @@
+peekabot is a distributed real-time 3D visualization tool for robotics
+researchers and developers, written in C++.
+
+Its purpose is to simplify the visualization needs faced by a roboticist
+daily - using visualization as a debugging aid or making fancy slides for
+a presentation, for example.
+
+Chris Petrik (chris@officialunix.com)
+WWW: http://www.peekabot.org
diff --git a/science/peekabot/pkg-plist b/science/peekabot/pkg-plist
new file mode 100644
index 000000000000..cf200f12ff49
--- /dev/null
+++ b/science/peekabot/pkg-plist
@@ -0,0 +1,111 @@
+bin/obj2pbmf
+bin/peekabot
+include/peekabot.hh
+include/peekabot/Action.hh
+include/peekabot/Deprecated.hh
+include/peekabot/Matrix.hh
+include/peekabot/PathIdentifier.hh
+include/peekabot/Types.hh
+include/peekabot/Vector.hh
+include/peekabot/client/DelayedDispatch.hh
+include/peekabot/client/Exceptions.hh
+include/peekabot/client/OperationResult.hh
+include/peekabot/client/OperationStatus.hh
+include/peekabot/client/PeekabotClient.hh
+include/peekabot/client/Recording.hh
+include/peekabot/client/Result.hh
+include/peekabot/client/Status.hh
+include/peekabot/client/any_dl.hpp
+include/peekabot/client/proxies/CameraProxy.hh
+include/peekabot/client/proxies/CircleProxy.hh
+include/peekabot/client/proxies/CubeProxy.hh
+include/peekabot/client/proxies/CylinderProxy.hh
+include/peekabot/client/proxies/GridProxy.hh
+include/peekabot/client/proxies/GroupProxy.hh
+include/peekabot/client/proxies/HingeProxy.hh
+include/peekabot/client/proxies/JointProxy.hh
+include/peekabot/client/proxies/LabelProxy.hh
+include/peekabot/client/proxies/LineBasedProxy.hh
+include/peekabot/client/proxies/LineCloudProxy.hh
+include/peekabot/client/proxies/ModelProxy.hh
+include/peekabot/client/proxies/ObjectProxy.hh
+include/peekabot/client/proxies/OccupancyGrid2DProxy.hh
+include/peekabot/client/proxies/PeekabotProxyBase.hh
+include/peekabot/client/proxies/PointCloudProxy.hh
+include/peekabot/client/proxies/PolygonProxy.hh
+include/peekabot/client/proxies/ScalableProxy.hh
+include/peekabot/client/proxies/SensorProxy.hh
+include/peekabot/client/proxies/SliderProxy.hh
+include/peekabot/client/proxies/SphereProxy.hh
+include/peekabot/client/proxies/VertexBasedProxy.hh
+lib/libpeekabot.a
+lib/libpeekabot.la
+lib/libpeekabot.so
+lib/libpeekabot.so.4
+%%DATADIR%%/data/default_scene.xml
+%%DATADIR%%/fonts/COPYING
+%%DATADIR%%/fonts/FreeSerif.ttf
+%%DATADIR%%/images/add_camera.png
+%%DATADIR%%/images/camera_object.png
+%%DATADIR%%/images/camera_object2.png
+%%DATADIR%%/images/camera_object3.png
+%%DATADIR%%/images/circle_object.png
+%%DATADIR%%/images/cont_snapshot.png
+%%DATADIR%%/images/cube_object.png
+%%DATADIR%%/images/cube_object_aa.png
+%%DATADIR%%/images/cylinder_object.png
+%%DATADIR%%/images/cylinder_object_aa.png
+%%DATADIR%%/images/dof.png
+%%DATADIR%%/images/grid.png
+%%DATADIR%%/images/groundplane.png
+%%DATADIR%%/images/group_object.png
+%%DATADIR%%/images/label.png
+%%DATADIR%%/images/light_object.png
+%%DATADIR%%/images/line_cloud.png
+%%DATADIR%%/images/locked.png
+%%DATADIR%%/images/move.png
+%%DATADIR%%/images/occupancy_grid_2d.png
+%%DATADIR%%/images/ortho_mode.png
+%%DATADIR%%/images/ortho_mode_aa.png
+%%DATADIR%%/images/perspective_mode.png
+%%DATADIR%%/images/perspective_mode_aa.png
+%%DATADIR%%/images/point_cloud.png
+%%DATADIR%%/images/polygon_object.png
+%%DATADIR%%/images/polyline_object.png
+%%DATADIR%%/images/polyline_object_aa.png
+%%DATADIR%%/images/rotate.png
+%%DATADIR%%/images/sensor_object.png
+%%DATADIR%%/images/snapshot.png
+%%DATADIR%%/images/snapshot_disabled.png
+%%DATADIR%%/images/sphere_object.png
+%%DATADIR%%/images/teapot.png
+%%DATADIR%%/images/topdown.png
+%%DATADIR%%/images/topdown_aa.png
+%%DATADIR%%/schemas/basic_types.xsd
+%%DATADIR%%/schemas/camera.xsd
+%%DATADIR%%/schemas/circle.xsd
+%%DATADIR%%/schemas/cube.xsd
+%%DATADIR%%/schemas/cylinder.xsd
+%%DATADIR%%/schemas/grid.xsd
+%%DATADIR%%/schemas/group.xsd
+%%DATADIR%%/schemas/hinge.xsd
+%%DATADIR%%/schemas/include.xsd
+%%DATADIR%%/schemas/label.xsd
+%%DATADIR%%/schemas/line_cloud.xsd
+%%DATADIR%%/schemas/model.xsd
+%%DATADIR%%/schemas/point_cloud.xsd
+%%DATADIR%%/schemas/polygon.xsd
+%%DATADIR%%/schemas/property_types.xsd
+%%DATADIR%%/schemas/scene.xsd
+%%DATADIR%%/schemas/scene_object.xsd
+%%DATADIR%%/schemas/sensor.xsd
+%%DATADIR%%/schemas/slider.xsd
+%%DATADIR%%/schemas/sphere.xsd
+@dirrm %%DATADIR%%/schemas
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm include/peekabot/client/proxies
+@dirrm include/peekabot/client
+@dirrm include/peekabot