aboutsummaryrefslogtreecommitdiff
path: root/science/py-asdf
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-31 11:24:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-31 11:41:12 +0000
commitaec044501eb30df5ec140ba0a929c2421700117b (patch)
tree280544b59f5fd50b8164147bf66ac3eb70c8821b /science/py-asdf
parent6765131a95d64c12db0ff2f0d726b3216ba44b5c (diff)
downloadports-aec044501eb30df5ec140ba0a929c2421700117b.tar.gz
ports-aec044501eb30df5ec140ba0a929c2421700117b.zip
Diffstat (limited to 'science/py-asdf')
-rw-r--r--science/py-asdf/Makefile8
-rw-r--r--science/py-asdf/distinfo6
-rw-r--r--science/py-asdf/files/setup.py67
3 files changed, 75 insertions, 6 deletions
diff --git a/science/py-asdf/Makefile b/science/py-asdf/Makefile
index b39d89f2ca6a..1f019aff334a 100644
--- a/science/py-asdf/Makefile
+++ b/science/py-asdf/Makefile
@@ -1,5 +1,5 @@
PORTNAME= asdf
-PORTVERSION= 2.12.0
+PORTVERSION= 2.13.0
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +10,10 @@ COMMENT= Python tools to handle ASDF files
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asdf-standard>=1.0.1:science/py-asdf-standard@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asdf-transform-schemas>=0.2.2:science/py-asdf-transform-schemas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jmespath>=0.6.2:devel/py-jmespath@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.0.1:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.0.1<4.10.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lz4>=0.10:archivers/py-lz4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=16.0:devel/py-packaging@${PY_FLAVOR} \
@@ -32,4 +31,7 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=3:devel/py-importlib-resources@${PY_FLAVOR}
.endif
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.post.mk>
diff --git a/science/py-asdf/distinfo b/science/py-asdf/distinfo
index ec759770ce3a..8a3b6450bc2e 100644
--- a/science/py-asdf/distinfo
+++ b/science/py-asdf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1654708390
-SHA256 (asdf-2.12.0.tar.gz) = 5914834d077ba3bf68b9aafdc646b9f27ce5e56e1c241167d461dee43b1023e9
-SIZE (asdf-2.12.0.tar.gz) = 450167
+TIMESTAMP = 1661599311
+SHA256 (asdf-2.13.0.tar.gz) = 32e2a69a53d1701fc4616e800fb3daff81bbad801832a7bf563e3b61c9fe3dfe
+SIZE (asdf-2.13.0.tar.gz) = 481609
diff --git a/science/py-asdf/files/setup.py b/science/py-asdf/files/setup.py
new file mode 100644
index 000000000000..66f3f82bf4c9
--- /dev/null
+++ b/science/py-asdf/files/setup.py
@@ -0,0 +1,67 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['asdf',
+ 'asdf.commands',
+ 'asdf.commands.tests',
+ 'asdf.commands.tests.data',
+ 'asdf.compat',
+ 'asdf.extension',
+ 'asdf.extern',
+ 'asdf.tags',
+ 'asdf.tags.core',
+ 'asdf.tags.core.tests',
+ 'asdf.tags.core.tests.data',
+ 'asdf.testing',
+ 'asdf.tests',
+ 'asdf.tests.data']
+
+package_data = \
+{'': ['*']}
+
+install_requires = \
+['asdf-standard >=1.0.1',
+ 'asdf-transform-schemas >=0.2.2',
+ 'jmespath >=0.6.2',
+ 'jsonschema >=4.0.1, <4.10.0',
+ 'numpy >=1.10',
+ 'packaging >=16.0',
+ 'pyyaml >=3.10',
+ 'semantic_version >=2.8']
+
+extras_require = \
+{':python_version <"3.9"': ['importlib_resources >=3'],
+ 'all': ['lz4 >=0.10'],
+ 'docs': ['sphinx-asdf >=0.1.4'],
+ 'tests': ['astropy >=5.0.4',
+ 'gwcs',
+ 'pytest-doctestplus',
+ 'pytest-remotedata',
+ 'pytest-openfiles',
+ 'psutil',
+ 'lz4 >=0.10'],
+ 'tests:sys_platform !="win32"': ['pytest >=6.0.0'],
+ 'tests:sys_platform =="win32"': ['pytest !=7.1.0, !=7.1.1, !=7.1.2']}
+
+entry_points = \
+{'onsole_scripts': ['asdftool = asdf.commands.main:main'],
+ 'asdf_extensions': ['builtin = asdf.extension:BuiltinExtension'],
+ 'asdf.resource_mappings': ['asdf = asdf.resource:get_json_schema_resource_mappings'],
+ 'pytest11': ['asdf_schema_tester = pytest_asdf.plugin']}
+
+setup(name='asdf',
+ version='%%PORTVERSION%%',
+ description='Python implementation of the ASDF Standard',
+ author=None,
+ author_email='The ASDF Developers <help@stsci.edu>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ install_requires=install_requires,
+ extras_require=extras_require,
+ entry_points=entry_points,
+ python_requires='>=3.8',
+ )