aboutsummaryrefslogtreecommitdiff
path: root/science/py-h5py/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-13 14:07:16 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-13 14:07:16 +0000
commit9921e14e14537c8d7854d9a55645d987ae75f199 (patch)
tree774e58fa69fa27823c8aa62a377abc218469da68 /science/py-h5py/Makefile
parent91e96b8369406a32463b653c4ce5dee7d0ec3237 (diff)
downloadports-9921e14e14537c8d7854d9a55645d987ae75f199.tar.gz
ports-9921e14e14537c8d7854d9a55645d987ae75f199.zip
Notes
Diffstat (limited to 'science/py-h5py/Makefile')
-rw-r--r--science/py-h5py/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
new file mode 100644
index 000000000000..a9d959da798a
--- /dev/null
+++ b/science/py-h5py/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: h5py
+# Date created: Jun 22, 2009
+# Whom: TAOKA Fumiyoshi
+#
+# $FreeBSD$
+#
+
+PORTNAME= h5py
+PORTVERSION= 1.2.0
+CATEGORIES= science python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= fmysh@iijmio-mail.jp
+COMMENT= A general-purpose Python interface to the HDF5 library
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.mk>