aboutsummaryrefslogtreecommitdiff
path: root/science/py-netCDF4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:18:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:18:45 +0000
commit7d22134ae14a42bbcae536f8580ac199c0454284 (patch)
tree091aef0d6834807c6a81244690ebb61470aa893d /science/py-netCDF4/Makefile
parent58d4bedcf436d78626be690db5da02da3064a913 (diff)
Notes
Diffstat (limited to 'science/py-netCDF4/Makefile')
-rw-r--r--science/py-netCDF4/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
new file mode 100644
index 000000000000..8740f2e1df34
--- /dev/null
+++ b/science/py-netCDF4/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: netCDF4
+# Date created: 18 Feb, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= netCDF4
+PORTVERSION= 0.7.7
+CATEGORIES= science python
+MASTER_SITES= http://netcdf4-python.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Interface to the NetCDF Library(versions 3 and 4)
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \
+ netcdf.5:${PORTSDIR}/science/netcdf4
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>