aboutsummaryrefslogtreecommitdiff
path: root/science/py-obspy.signal/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-14 14:09:29 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-14 14:09:29 +0000
commitac49b69bf56e0219aa22fc69cfc7ecbf2058b6a9 (patch)
tree4f48ff886d25243ef6a32828a3803e9afa53b6d9 /science/py-obspy.signal/Makefile
parent53ab78064bbd5c238c1d9e63f6996ef923b4caa6 (diff)
downloadports-ac49b69bf56e0219aa22fc69cfc7ecbf2058b6a9.tar.gz
ports-ac49b69bf56e0219aa22fc69cfc7ecbf2058b6a9.zip
Notes
Diffstat (limited to 'science/py-obspy.signal/Makefile')
-rw-r--r--science/py-obspy.signal/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/science/py-obspy.signal/Makefile b/science/py-obspy.signal/Makefile
new file mode 100644
index 000000000000..2dbba5d37b62
--- /dev/null
+++ b/science/py-obspy.signal/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-obspy.signal
+# Date created: Jan 26, 2011
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= obspy.signal
+PORTVERSION= 0.4.7
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Python signal processing routines for seismology
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}obspy.core>=0.4.6:${PORTSDIR}/science/py-obspy.core
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_ZIP= yes
+USE_PYTHON= yes
+PYEASYINSTALL_ARCHDEP= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>