aboutsummaryrefslogtreecommitdiff
path: root/science/pyvox/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-22 06:52:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-22 06:52:25 +0000
commit6915f3f05b23bd5af4f54b7945017238aa707e70 (patch)
treea1c71e1f6b492248e9bcf1ee037029e6d698f2f2 /science/pyvox/Makefile
parenta05aa886451c1b85fee268a1611e76a65ca5f912 (diff)
downloadports-6915f3f05b23bd5af4f54b7945017238aa707e70.tar.gz
ports-6915f3f05b23bd5af4f54b7945017238aa707e70.zip
Notes
Diffstat (limited to 'science/pyvox/Makefile')
-rw-r--r--science/pyvox/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/science/pyvox/Makefile b/science/pyvox/Makefile
new file mode 100644
index 000000000000..6271392638fd
--- /dev/null
+++ b/science/pyvox/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection Makefile for: bblimage
+# Date created: Jul 22, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= bblimage
+PORTVERSION= 0.66
+CATEGORIES= science
+MASTER_SITES= http://www.uphs.upenn.edu/bbl/software/files/
+EXTRACT_SUFX= .src.tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-lapack --with-python
+USE_GMAKE= yes
+
+MAN1= anonbblanz.1 bblimage.1 binnseg.1 conseg.1 decomment.1 dumpbblanz.1 \
+ imstack.1 inleav2.1 lovar.1 qdv.1 rpsamp.1 skmiv.1 swab.1 usb2uc.1 \
+ vibihist.1 vihist.1
+MAN5= cdata.5 mri_data.5 param.5
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|1\.5|2.2|g" ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>