aboutsummaryrefslogtreecommitdiff
path: root/science/pyvox
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-09 02:47:51 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-10-09 02:47:51 +0000
commitc3ef22e5074da76f3c1ee829ef48d204ce040fc8 (patch)
treee774af268961483556ceccc49ef1a585f2e45ce0 /science/pyvox
parentb701e182a654c26eba0d8736d26c90cc1ffc7811 (diff)
downloadports-c3ef22e5074da76f3c1ee829ef48d204ce040fc8.tar.gz
ports-c3ef22e5074da76f3c1ee829ef48d204ce040fc8.zip
Notes
Diffstat (limited to 'science/pyvox')
-rw-r--r--science/pyvox/Makefile69
-rw-r--r--science/pyvox/distinfo2
-rw-r--r--science/pyvox/files/patch-src__parray.c76
-rw-r--r--science/pyvox/files/patch-src__pyvox.c20
-rw-r--r--science/pyvox/files/patch-src__tkphoto.c11
-rw-r--r--science/pyvox/pkg-descr12
-rw-r--r--science/pyvox/pkg-plist26
7 files changed, 0 insertions, 216 deletions
diff --git a/science/pyvox/Makefile b/science/pyvox/Makefile
deleted file mode 100644
index 8e940556cb39..000000000000
--- a/science/pyvox/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-# ex:ts=8
-# Ports collection Makefile for: bblimage
-# Date created: Jul 22, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= pyvox
-PORTVERSION= 0.72
-CATEGORIES= science
-MASTER_SITES= http://www.med.upenn.edu/bbl/downloads/pyvox/
-EXTRACT_SUFX= .src.tgz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A set of software tools for medical image processing
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-LICENSE= MIT
-
-LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack
-
-GNU_CONFIGURE= yes
-LAPACK?= -llapack -lblas
-CONFIGURE_ARGS = --with-lapack="${LAPACK}" --with-python="${PYTHON_CMD}"
-CONFIGURE_ENV= ac_cv_header_tgmath_h=no
-USE_GMAKE= yes
-USE_LDCONFIG= yes
-USE_PYTHON= 2.5+
-
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--without-x
-PLIST_SUB+= X11="@comment "
-.else
-CONFIGURE_ARGS+=--with-x
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
-USE_MOTIF= yes
-USE_TK = 82+
-CFLAGS+= -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK -I${LOCALBASE}/include \
- -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
-PLIST_SUB+= X11=""
-.endif
-
-MAN1= affreg.1 anonavw.1 bredit.1 decomment.1 dumpavw.1 editavw.1 makeavw.1 pyvox.1 \
- reged.1 regedit.1 qdv.1
-MAN5= cdata.5 param.5
-
-.include <bsd.port.pre.mk>
-
-post-patch:
-.if defined(WITHOUT_X11)
- @${REINPLACE_CMD} -e '\|pmw=yes|s|yes|no|' -e '\|tkinter=yes|s|yes|no|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '\|#include "tk.h"|d' ${WRKSRC}/include/pyvox.h
-.else
- @${REINPLACE_CMD} -e 's|-ltk|&${USE_TK}|' \
- ${WRKSRC}/Makefile.in
-.endif
-
-.if defined(MAINTAINER_MODE)
-check regress regression-test test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} regress)
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/science/pyvox/distinfo b/science/pyvox/distinfo
deleted file mode 100644
index 62547d6b3ece..000000000000
--- a/science/pyvox/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pyvox-0.72.src.tgz) = d7a733faa323d8cdca51e8244e9c50c91bccbb77543e546125f7b251a3c75a61
-SIZE (pyvox-0.72.src.tgz) = 1501027
diff --git a/science/pyvox/files/patch-src__parray.c b/science/pyvox/files/patch-src__parray.c
deleted file mode 100644
index a84acca50fdd..000000000000
--- a/science/pyvox/files/patch-src__parray.c
+++ /dev/null
@@ -1,76 +0,0 @@
---- ./src/parray.c.orig 2006-02-24 12:18:51.000000000 -0500
-+++ ./src/parray.c 2011-07-01 02:32:12.000000000 -0400
-@@ -991,7 +991,7 @@
- if (DEBUG_ALLOC) {
- fprintf(stderr, "parray create: %p\n", self);
- if (0)
-- fprintf(stderr, "...reference count = %d\n",
-+ fprintf(stderr, "...reference count = %zd\n",
- ((PyObject *)self)->ob_refcnt);
- }
-
-@@ -1171,7 +1171,7 @@
- if (DEBUG_ALLOC) {
- fprintf(stderr, "parray alloc: %p\n", self);
- if (0)
-- fprintf(stderr, "...reference count = %d\n",
-+ fprintf(stderr, "...reference count = %zd\n",
- ((PyObject *)self)->ob_refcnt);
- }
-
-@@ -2074,7 +2074,7 @@
-
- static PyMappingMethods
- parray_as_mapping = {
-- (inquiry) parray_length, /* mp_length: len(x) */
-+ (lenfunc) parray_length, /* mp_length: len(x) */
- (binaryfunc) parray_getitem, /* mp_subscript: x[y] */
- (objobjargproc) parray_setitem, /* mp_ass_subscript: x[y] = v */
- };
-@@ -2204,13 +2204,13 @@
-
- static PySequenceMethods
- parray_as_sequence = {
-- (inquiry) 0, /* sq_length: len(x) */
-+ (lenfunc) 0, /* sq_length: len(x) */
- (binaryfunc) 0, /* sq_concat: x + y */
-- (intargfunc) 0, /* sq_repeat: n * x */
-- (intargfunc) 0, /* sq_item: x[i] */
-- (intintargfunc) parray_getslice, /* sq_slice: x[i:j] */
-- (intobjargproc) 0, /* sq_ass_item: x[i] = v */
-- (intintobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
-+ (ssizeargfunc) 0, /* sq_repeat: n * x */
-+ (ssizeargfunc) 0, /* sq_item: x[i] */
-+ (ssizessizeargfunc) parray_getslice, /* sq_slice: x[i:j] */
-+ (ssizeobjargproc) 0, /* sq_ass_item: x[i] = v */
-+ (ssizessizeobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
- };
-
-
-@@ -7386,7 +7386,7 @@
-
- /* DEBUG: Print ref counts of arguments */
- if (0) {
-- printf("Refcnts 1: %d, %d\n", self->ob_refcnt, filename->ob_refcnt);
-+ printf("Refcnts 1: %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt);
- }
-
- /* Paste self onto front of argument tuple. FIXME: This is really
-@@ -7400,7 +7400,7 @@
-
- /* DEBUG: Print ref counts of arguments */
- if (0) {
-- printf("Refcnts 2: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
-+ printf("Refcnts 2: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
- newargs->ob_refcnt);
- }
-
-@@ -7418,7 +7418,7 @@
-
- /* DEBUG: Print ref counts of arguments */
- if (0) {
-- printf("Refcnts 3: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
-+ printf("Refcnts 3: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
- newargs->ob_refcnt);
- }
-
diff --git a/science/pyvox/files/patch-src__pyvox.c b/science/pyvox/files/patch-src__pyvox.c
deleted file mode 100644
index 07f056943e7d..000000000000
--- a/science/pyvox/files/patch-src__pyvox.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/pyvox.c.orig 2006-02-24 16:33:41.000000000 -0500
-+++ ./src/pyvox.c 2011-07-01 02:29:06.000000000 -0400
-@@ -1850,7 +1850,7 @@
- if (0) {
- fprintf(stderr, "Created new kernel object at %p\n", self);
- if (0)
-- fprintf(stderr, "...reference count = %d\n",
-+ fprintf(stderr, "...reference count = %zd\n",
- ((PyObject *)self)->ob_refcnt);
- }
-
-@@ -2273,7 +2273,7 @@
-
- static PyMappingMethods
- kernel_as_mapping = {
-- (inquiry) kernel_length, /* mp_length: len(x) */
-+ (lenfunc) kernel_length, /* mp_length: len(x) */
- (binaryfunc) kernel_getitem, /* mp_subscript: x[y] */
- (objobjargproc) kernel_setitem, /* mp_ass_subscript: x[y] = v */
- };
diff --git a/science/pyvox/files/patch-src__tkphoto.c b/science/pyvox/files/patch-src__tkphoto.c
deleted file mode 100644
index 9be4a5503b5f..000000000000
--- a/science/pyvox/files/patch-src__tkphoto.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/tkphoto.c.orig 2005-12-29 13:33:15.000000000 -0500
-+++ ./src/tkphoto.c 2011-07-01 02:28:06.000000000 -0400
-@@ -632,7 +632,7 @@
- if (0) {
- fprintf(stderr, "Created new tkphoto object at %p\n", self);
- if (0)
-- fprintf(stderr, "...reference count = %d\n",
-+ fprintf(stderr, "...reference count = %zd\n",
- ((PyObject *)pytk)->ob_refcnt);
- }
-
diff --git a/science/pyvox/pkg-descr b/science/pyvox/pkg-descr
deleted file mode 100644
index 02eb66e38c1e..000000000000
--- a/science/pyvox/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Pyvox (formerly known as BBLimage) is a set of software tools for medical
-image processing, particularly skull stripping and segmentation of MR brain
-images (tools to support other applications may be added later). These tools
-are intended to support researchers who need to prototype new image analysis
-algorithms or to develop automated image analysis tools for specific image
-analysis applications. The sequence of processing operations is specified
-through the scripting language Python, which can be used interactively or in
-command files.
-
-Pyvox scripts and date files are portable, easily extensible, and suitable
-both for rapid prototyping of new algorithms and analysis protocols, and also
-for efficient, automated processing of the finished analysis protocols.
diff --git a/science/pyvox/pkg-plist b/science/pyvox/pkg-plist
deleted file mode 100644
index 2d3ecb6c87dd..000000000000
--- a/science/pyvox/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-bin/affreg
-bin/anonavw
-bin/bredit
-bin/decomment
-bin/dumpavw
-bin/editavw
-bin/makeavw
-%%X11%%bin/qdv
-bin/regedit
-include/errm.h
-include/exim.h
-include/memm.h
-include/voxel.h
-lib/libpyvox.so
-lib/libvoxkit.so
-%%PYTHON_SITELIBDIR%%/exim.so
-%%PYTHON_SITELIBDIR%%/optim.py
-%%PYTHON_SITELIBDIR%%/optim.pyc
-%%PYTHON_SITELIBDIR%%/pyvox.py
-%%PYTHON_SITELIBDIR%%/pyvox.pyc
-%%PYTHON_SITELIBDIR%%/pyvoxC.so
-%%PYTHON_SITELIBDIR%%/reged.py
-%%PYTHON_SITELIBDIR%%/reged.pyc
-%%PYTHON_SITELIBDIR%%/regis.py
-%%PYTHON_SITELIBDIR%%/regis.pyc
-%%X11%%%%PYTHON_SITELIBDIR%%/tkphoto.so