aboutsummaryrefslogtreecommitdiff
path: root/science/vipster
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-21 07:07:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-21 07:07:34 +0000
commit083835b7506f836aea2b9fd70cbd524570e0518e (patch)
treef4436a31e0b884c2571b463ad3d6bb67b2826524 /science/vipster
parent5f5f2f496b2b445639a1305cd7eb77c0c6809fbf (diff)
downloadports-083835b7506f836aea2b9fd70cbd524570e0518e.tar.gz
ports-083835b7506f836aea2b9fd70cbd524570e0518e.zip
Notes
Diffstat (limited to 'science/vipster')
-rw-r--r--science/vipster/Makefile31
-rw-r--r--science/vipster/distinfo3
-rw-r--r--science/vipster/files/patch-libvipster_configfile.h11
-rw-r--r--science/vipster/pkg-descr4
-rw-r--r--science/vipster/pkg-plist43
5 files changed, 92 insertions, 0 deletions
diff --git a/science/vipster/Makefile b/science/vipster/Makefile
new file mode 100644
index 000000000000..ad8f00576c5c
--- /dev/null
+++ b/science/vipster/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= vipster
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.14a
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Crystalline and molecular structure visualisation program
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource compiler:c++17-lang
+USE_GITHUB= yes
+GH_ACCOUNT= sgsaenger
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DESKTOP PYTHON
+OPTIONS_DEFAULT= DESKTOP
+OPTIONS_SUB= yes
+
+DESKTOP_DESC= Build QT-based desktop app
+DESKTOP_CMAKE_BOOL= DESKTOP
+DESKTOP_USES= qt:5
+DESKTOP_USE= QT=core,gui,widgets,buildtools_build,qmake_build
+
+PYTHON_CMAKE_BOOL= PYTHON
+PYTHON_BROKEN= Bundles pybind11: https://repology.org/metapackage/pybind11/versions
+
+.include <bsd.port.mk>
diff --git a/science/vipster/distinfo b/science/vipster/distinfo
new file mode 100644
index 000000000000..d2fe69fa7f88
--- /dev/null
+++ b/science/vipster/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545372820
+SHA256 (sgsaenger-vipster-v1.14a_GH0.tar.gz) = 217164469671f7f52850a56e04772b6c0b83ec3b0ffbb214bc54d9e84bb9daf2
+SIZE (sgsaenger-vipster-v1.14a_GH0.tar.gz) = 1090234
diff --git a/science/vipster/files/patch-libvipster_configfile.h b/science/vipster/files/patch-libvipster_configfile.h
new file mode 100644
index 000000000000..26dd67a6dfba
--- /dev/null
+++ b/science/vipster/files/patch-libvipster_configfile.h
@@ -0,0 +1,11 @@
+--- libvipster/configfile.h.orig 2018-12-21 06:15:43 UTC
++++ libvipster/configfile.h
+@@ -27,7 +27,7 @@ bool saveConfig();
+ #ifdef __EMSCRIPTEN__
+ const std::string user_path{}; // not used
+ const std::string user_config{}; // not used
+-#elif __linux__
++#elif __linux__ || defined(__FreeBSD__)
+ const std::string user_path = [](){
+ auto tmp = std::getenv("XDG_CONFIG_HOME");
+ return tmp == nullptr ? std::string{std::getenv("HOME")}+"/.config" : tmp;
diff --git a/science/vipster/pkg-descr b/science/vipster/pkg-descr
new file mode 100644
index 000000000000..db05a0588fc7
--- /dev/null
+++ b/science/vipster/pkg-descr
@@ -0,0 +1,4 @@
+vipster is a visualization and editing framework for atomistic simulations.
+It allows to visualize various molecular structure files.
+
+WWW: https://sgsaenger.github.io/vipster/
diff --git a/science/vipster/pkg-plist b/science/vipster/pkg-plist
new file mode 100644
index 000000000000..467940ad2265
--- /dev/null
+++ b/science/vipster/pkg-plist
@@ -0,0 +1,43 @@
+%%DESKTOP%%bin/vipster
+include/libvipster/atom.h
+include/libvipster/atomcontainers.h
+include/libvipster/bond.h
+include/libvipster/cell.h
+include/libvipster/configfile.h
+include/libvipster/crystal.h
+include/libvipster/data.h
+include/libvipster/global.h
+include/libvipster/io.h
+include/libvipster/io/configs.h
+include/libvipster/io/cpmdinput/config.h
+include/libvipster/io/cpmdinput/param.h
+include/libvipster/io/cpmdinput/plugin.h
+include/libvipster/io/cube/plugin.h
+include/libvipster/io/fmt.h
+include/libvipster/io/lmpinput/config.h
+include/libvipster/io/lmpinput/plugin.h
+include/libvipster/io/lmptrajec/plugin.h
+include/libvipster/io/parameters.h
+include/libvipster/io/plugin.h
+include/libvipster/io/pwinput/config.h
+include/libvipster/io/pwinput/param.h
+include/libvipster/io/pwinput/plugin.h
+include/libvipster/io/pwoutput/plugin.h
+include/libvipster/io/xsf/plugin.h
+include/libvipster/io/xyz/config.h
+include/libvipster/io/xyz/plugin.h
+include/libvipster/kpoints.h
+include/libvipster/molecule.h
+include/libvipster/pse.h
+include/libvipster/settings.h
+include/libvipster/step.h
+include/libvipster/stepconst.h
+include/libvipster/stepmutable.h
+include/libvipster/stepsel.h
+include/libvipster/vec.h
+lib/libvipster.so
+lib/libvipster.so.1
+lib/libvipster.so.1.14
+%%DESKTOP%%share/applications/vipster.desktop
+%%DESKTOP%%share/icons/hicolor/128x128/apps/vipster.png
+%%DESKTOP%%share/metainfo/vipster.appdata.xml