aboutsummaryrefslogtreecommitdiff
path: root/science/vis5d+/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-06 23:44:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-06 23:44:36 +0000
commit881afb1532172e024d2098e745b4ec7f2612f5e3 (patch)
treee074e01553825bff4e390a841d64e7a77f6e2f19 /science/vis5d+/Makefile
parent9fb35023ed45dc08b766459b4675edb7b6e0471f (diff)
- Fix build on 5.x
PR: ports/59613 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=95210
Diffstat (limited to 'science/vis5d+/Makefile')
-rw-r--r--science/vis5d+/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 0823c19e9bcf..d7a5fc1f3251 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -23,22 +23,17 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
-USE_MESA= yes
-USE_GNOME= gtk12
-USE_LIBTOOL= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_GL= yes
+USE_GNOME= gnometarget gtk12
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-gtk --enable-threads --with-mesa --with-netcdf \
+CONFIGURE_ARGS= --enable-gtk --enable-threads --with-netcdf \
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_FLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>