aboutsummaryrefslogtreecommitdiff
path: root/science/xdrawchem
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-13 00:52:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-13 00:52:20 +0000
commitb474c9ac63e8672c45bdae888a18f5ba28cf9864 (patch)
treefe1f04da391e509afb0c94d385b0b8d316b5b3f3 /science/xdrawchem
parenta29d767ef41148909c745a9491b5b86bdb2724ae (diff)
downloadports-b474c9ac63e8672c45bdae888a18f5ba28cf9864.tar.gz
ports-b474c9ac63e8672c45bdae888a18f5ba28cf9864.zip
Notes
Diffstat (limited to 'science/xdrawchem')
-rw-r--r--science/xdrawchem/Makefile16
-rw-r--r--science/xdrawchem/distinfo6
-rw-r--r--science/xdrawchem/files/patch-xdrawchem.pro41
-rw-r--r--science/xdrawchem/files/patch-xdrawchem_ioiface.cpp38
-rw-r--r--science/xdrawchem/files/patch-xdrawchem_ioiface.h12
-rw-r--r--science/xdrawchem/files/patch-xdrawchem_molecule.h13
-rw-r--r--science/xdrawchem/files/patch-xdrawchem_molecule__obmol.cpp47
-rw-r--r--science/xdrawchem/files/patch-xdrawchem_molecule__smiles.cpp32
-rw-r--r--science/xdrawchem/pkg-plist123
9 files changed, 48 insertions, 280 deletions
diff --git a/science/xdrawchem/Makefile b/science/xdrawchem/Makefile
index 516f2bfcab92..da71e432c973 100644
--- a/science/xdrawchem/Makefile
+++ b/science/xdrawchem/Makefile
@@ -1,25 +1,25 @@
# $FreeBSD$
PORTNAME= xdrawchem
-DISTVERSION= 1.10.2-1
-PORTREVISION= 4
+DISTVERSION= 1.11.0-2
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
COMMENT= Two-dimensional molecule drawing program
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/doc/GPL.txt
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libopenbabel.so:science/openbabel
USES= compiler:c++11-lang gl qmake qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= bryanherger
-USE_QT= core gui network printsupport widgets xml buildtools_build
+USE_QT= core gui network printsupport svg widgets xml buildtools_build
USE_GL= gl
-WRKSRC_SUBDIR= ${PORTNAME}-qt5
+USE_GITLAB= yes
+GL_SITE= https://salsa.debian.org
+GL_ACCOUNT= georgesk
+GL_COMMIT= a3f74c34eb09fa72ee16848ec6901049ca5309d5
pre-configure:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/science/xdrawchem/distinfo b/science/xdrawchem/distinfo
index 36ae22c6fb2a..5cea513623a6 100644
--- a/science/xdrawchem/distinfo
+++ b/science/xdrawchem/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533775206
-SHA256 (bryanherger-xdrawchem-1.10.2-1_GH0.tar.gz) = 009b525e570cd79b3e59880877871e258071fecdef6c397d7533f3920faa9a7e
-SIZE (bryanherger-xdrawchem-1.10.2-1_GH0.tar.gz) = 2888990
+TIMESTAMP = 1610498160
+SHA256 (georgesk-xdrawchem-a3f74c34eb09fa72ee16848ec6901049ca5309d5_GL0.tar.gz) = 856ac96c7e5a71270dc3fdf90a7c3e453b8f13f53167fd266635177a61370e85
+SIZE (georgesk-xdrawchem-a3f74c34eb09fa72ee16848ec6901049ca5309d5_GL0.tar.gz) = 719368
diff --git a/science/xdrawchem/files/patch-xdrawchem.pro b/science/xdrawchem/files/patch-xdrawchem.pro
index e61f3bb7e714..f5121eaf6e9b 100644
--- a/science/xdrawchem/files/patch-xdrawchem.pro
+++ b/science/xdrawchem/files/patch-xdrawchem.pro
@@ -1,13 +1,42 @@
---- xdrawchem.pro.orig 2017-01-09 12:25:32 UTC
+--- xdrawchem.pro.orig 2021-01-06 18:45:48 UTC
+++ xdrawchem.pro
-@@ -6,8 +6,8 @@ exists(/usr/include/openbabel-2.0/openbabel/mol.h) {
- INCLUDEPATH += /usr/include/openbabel-2.0
+@@ -2,17 +2,17 @@ TEMPLATE = app
+ TARGET = xdrawchem
+
+ # edit to match your OB install
+-exists(/usr/include/openbabel3/openbabel/mol.h) {
+-INCLUDEPATH += /usr/include/openbabel3
++exists(%%LOCALBASE%%/include/openbabel3/openbabel/mol.h) {
++INCLUDEPATH += %%LOCALBASE%%/include/openbabel3
LIBS += -lopenbabel
}
--exists(/usr/local/include/openbabel-2.0/openbabel/mol.h) {
--INCLUDEPATH += /usr/local/include/openbabel-2.0
+-exists(/usr/local/include/openbabel-3.0/openbabel/mol.h) {
+-INCLUDEPATH += /usr/local/include/openbabel-3.0
+exists(%%LOCALBASE%%/include/openbabel3/openbabel/mol.h) {
+INCLUDEPATH += %%LOCALBASE%%/include/openbabel3
LIBS += -lopenbabel
}
- exists(/Developer/openbabel-2.4.1/include/openbabel/mol.h) {
+-exists(/Developer/openbabel-3.0/include/openbabel/mol.h) {
+-INCLUDEPATH += /Developer/openbabel-3.0/include
+-LIBS += -L/Developer/openbabel-3.0/lib/Debug -lopenbabel
++exists(%%LOCALBASE%%/openbabel3/include/openbabel/mol.h) {
++INCLUDEPATH += /Developer/openbabel3/include
++LIBS += -L/Developer/openbabel3/lib/Debug -lopenbabel
+ }
+ # exit if openbabel wasn't found
+ contains( LIBS, -lopenbabel ) {
+@@ -20,12 +20,12 @@ contains( LIBS, -lopenbabel ) {
+ error(OpenBabel was not found. Edit xdrawchem.pro and add valid include and lib values)
+ # if you get this error, comment the above with #, uncomment the variables below, and set
+ # the paths to match your OpenBabel install
+-#INCLUDEPATH += /usr/local/include/openbabel-3.0
++#INCLUDEPATH += %%LOCALBASE%%/include/openbabel-3.0
+ #LIBS += -lopenbabel
+ }
+ # set PREFIX if not set (it is set when building RPM)
+ isEmpty(PREFIX) {
+-PREFIX = /usr/local
++PREFIX = %%LOCALBASE%%
+ }
+
+ DESTDIR = bin
diff --git a/science/xdrawchem/files/patch-xdrawchem_ioiface.cpp b/science/xdrawchem/files/patch-xdrawchem_ioiface.cpp
deleted file mode 100644
index 1f4f8fca8930..000000000000
--- a/science/xdrawchem/files/patch-xdrawchem_ioiface.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- xdrawchem/ioiface.cpp.orig 2017-01-09 12:25:32 UTC
-+++ xdrawchem/ioiface.cpp
-@@ -193,7 +193,7 @@ void IOIface::convertToChemData()
- int bondorder = bond->GetBondOrder();
-
- //set elements
-- if ( !atom1->IsCarbon() ) {
-+ if ( atom1->GetAtomicNum() != 6 ) {
- QString str( "<element>" );
- str += IOIface::symbol[atom1->GetAtomicNum() - 1];
- str += "</element>";
-@@ -201,7 +201,7 @@ void IOIface::convertToChemData()
-
- }
-
-- if ( !atom2->IsCarbon() ) {
-+ if ( atom2->GetAtomicNum() != 6 ) {
- QString str( "<element>" );
-
- str += IOIface::symbol[atom2->GetAtomicNum() - 1];
-@@ -216,7 +216,7 @@ void IOIface::convertToChemData()
-
- //label atoms if not Carbon
-
-- if ( !atom1->IsCarbon() ) {
-+ if ( atom1->GetAtomicNum() != 6 ) {
-
- text = new Text( chemdata->getRender2D() );
- QString str = IOIface::symbol[atom1->GetAtomicNum() - 1];
-@@ -229,7 +229,7 @@ void IOIface::convertToChemData()
- //qDebug() << "ioiface(1) text:" << str;
- }
-
-- if ( !atom2->IsCarbon() ) {
-+ if ( atom2->GetAtomicNum() != 6 ) {
-
- text = new Text( chemdata->getRender2D() );
- QString str = IOIface::symbol[atom2->GetAtomicNum() - 1];
diff --git a/science/xdrawchem/files/patch-xdrawchem_ioiface.h b/science/xdrawchem/files/patch-xdrawchem_ioiface.h
deleted file mode 100644
index 64aff36218cc..000000000000
--- a/science/xdrawchem/files/patch-xdrawchem_ioiface.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- xdrawchem/ioiface.h.orig 2017-01-09 12:25:32 UTC
-+++ xdrawchem/ioiface.h
-@@ -20,6 +20,9 @@
-
- #include "chemdata.h"
-
-+#include <openbabel/atom.h>
-+#include <openbabel/bond.h>
-+#include <openbabel/math/vector3.h>
- #include <openbabel/mol.h>
-
- using namespace OpenBabel;
diff --git a/science/xdrawchem/files/patch-xdrawchem_molecule.h b/science/xdrawchem/files/patch-xdrawchem_molecule.h
deleted file mode 100644
index 46612dda9a7c..000000000000
--- a/science/xdrawchem/files/patch-xdrawchem_molecule.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- xdrawchem/molecule.h.orig 2017-01-09 12:25:32 UTC
-+++ xdrawchem/molecule.h
-@@ -3,6 +3,10 @@
- #ifndef MOLECULE_H
- #define MOLECULE_H
-
-+#include <openbabel/atom.h>
-+#include <openbabel/bond.h>
-+#include <openbabel/elements.h>
-+#include <openbabel/math/vector3.h>
- #include <openbabel/mol.h>
- #include <openbabel/obconversion.h>
-
diff --git a/science/xdrawchem/files/patch-xdrawchem_molecule__obmol.cpp b/science/xdrawchem/files/patch-xdrawchem_molecule__obmol.cpp
deleted file mode 100644
index 9c7949a1b02a..000000000000
--- a/science/xdrawchem/files/patch-xdrawchem_molecule__obmol.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- xdrawchem/molecule_obmol.cpp.orig 2017-01-09 12:25:32 UTC
-+++ xdrawchem/molecule_obmol.cpp
-@@ -58,7 +58,7 @@ bool Molecule::convertFromOBMol( OBMol * obmol )
- Point point;
- Text *text;
-
-- std::vector < OBEdgeBase * >::iterator bonditr;
-+ std::vector < OBBond * >::iterator bonditr;
- std::map < Point, DPoint *, pt_cmp > points;
- std::map < Point, DPoint *, pt_cmp >::iterator itr;
-
-@@ -133,7 +133,7 @@ bool Molecule::convertFromOBMol( OBMol * obmol )
- int bondorder = bond->GetBondOrder();
-
- //set elements
-- if ( !atom1->IsCarbon() ) {
-+ if ( atom1->GetAtomicNum() != 6 ) {
- QString str( "<element>" );
-
- str += symbol[atom1->GetAtomicNum() - 1];
-@@ -142,7 +142,7 @@ bool Molecule::convertFromOBMol( OBMol * obmol )
-
- }
-
-- if ( !atom2->IsCarbon() ) {
-+ if ( atom2->GetAtomicNum() != 6 ) {
- QString str( "<element>" );
-
- str += symbol[atom2->GetAtomicNum() - 1];
-@@ -155,7 +155,7 @@ bool Molecule::convertFromOBMol( OBMol * obmol )
-
- //label atoms if not Carbon
-
-- if ( !atom1->IsCarbon() ) {
-+ if ( atom1->GetAtomicNum() != 6 ) {
-
- text = new Text( r );
- QString str = symbol[atom1->GetAtomicNum() - 1];
-@@ -167,7 +167,7 @@ bool Molecule::convertFromOBMol( OBMol * obmol )
- addText( text );
- }
-
-- if ( !atom2->IsCarbon() ) {
-+ if ( atom2->GetAtomicNum() != 6 ) {
-
- text = new Text( r );
- QString str = symbol[atom2->GetAtomicNum() - 1];
diff --git a/science/xdrawchem/files/patch-xdrawchem_molecule__smiles.cpp b/science/xdrawchem/files/patch-xdrawchem_molecule__smiles.cpp
deleted file mode 100644
index f9404fb11deb..000000000000
--- a/science/xdrawchem/files/patch-xdrawchem_molecule__smiles.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
---- xdrawchem/molecule_smiles.cpp.orig 2017-01-09 12:25:32 UTC
-+++ xdrawchem/molecule_smiles.cpp
-@@ -254,8 +254,6 @@ void Molecule::FromSMILES( QString sm )
-
- DPoint *thisDPoint;
-
-- OpenBabel::OBElementTable etable;
--
- std::vector < OpenBabel::OBNodeBase * >::iterator ait;
-
- std::map < OpenBabel::OBAtom *, DPoint * >hashit;
-@@ -265,9 +263,9 @@ void Molecule::FromSMILES( QString sm )
-
- qInfo() << "Adding OBAtom: " << i++ << " of element#: " <<
- thisAtom->GetAtomicNum() << " type: " <<
-- etable.GetSymbol(thisAtom->GetAtomicNum()) ;
-+ OBElements::GetSymbol(thisAtom->GetAtomicNum()) ;
- thisDPoint = new DPoint;
-- tmp_element = etable.GetSymbol( thisAtom->GetAtomicNum() );
-+ tmp_element = OBElements::GetSymbol( thisAtom->GetAtomicNum() );
-
- tmp_element_mask = tmp_element;
- tmp_element_mask.fill( ' ' ); // fix the mask characters
-@@ -292,7 +290,7 @@ void Molecule::FromSMILES( QString sm )
-
- OpenBabel::OBBond * thisBond;
-
-- std::vector < OpenBabel::OBEdgeBase * >::iterator bit;
-+ std::vector < OpenBabel::OBBond * >::iterator bit;
- for ( thisBond = myMol.BeginBond( bit ); thisBond; thisBond = myMol.NextBond( bit ) ) {
- addBond( hashit[thisBond->GetBeginAtom()], hashit[thisBond->GetEndAtom()], 1, thisBond->GetBondOrder(), QColor( 0, 0, 0 ), true );
- }
diff --git a/science/xdrawchem/pkg-plist b/science/xdrawchem/pkg-plist
index 1c6e58bc8f3e..19ad5725bff1 100644
--- a/science/xdrawchem/pkg-plist
+++ b/science/xdrawchem/pkg-plist
@@ -1,57 +1,9 @@
bin/xdrawchem
-%%DATADIR%%/6ring_boat.cml
-%%DATADIR%%/6ring_boat.png
-%%DATADIR%%/6ring_chair.cml
-%%DATADIR%%/6ring_chair.png
-%%DATADIR%%/CMakeLists.txt
%%DATADIR%%/COPYRIGHT.txt
-%%DATADIR%%/GPL.txt
-%%DATADIR%%/HISTORY.txt
-%%DATADIR%%/adenine.cml
-%%DATADIR%%/alanine.cml
-%%DATADIR%%/anthracene.cml
-%%DATADIR%%/arginine.cml
-%%DATADIR%%/arrowtool.png
-%%DATADIR%%/asparagine.cml
-%%DATADIR%%/aspartic_acid.cml
-%%DATADIR%%/back.xpm
-%%DATADIR%%/benzene.cml
-%%DATADIR%%/benzene.png
-%%DATADIR%%/biotin.cml
-%%DATADIR%%/biphenyl.cml
-%%DATADIR%%/boc.cml
-%%DATADIR%%/boldtool.png
-%%DATADIR%%/brackettool.png
-%%DATADIR%%/caslist.txt
-%%DATADIR%%/chaintool.png
-%%DATADIR%%/copytool.png
-%%DATADIR%%/curvearrowtool.png
-%%DATADIR%%/cuttool.png
-%%DATADIR%%/cyclobutane.cml
-%%DATADIR%%/cyclobutane.png
-%%DATADIR%%/cycloheptane.cml
-%%DATADIR%%/cyclohexane.cml
-%%DATADIR%%/cyclohexane.png
-%%DATADIR%%/cyclooctane.cml
-%%DATADIR%%/cyclopentadiene-sp.cml
-%%DATADIR%%/cyclopentadiene.cml
-%%DATADIR%%/cyclopentadiene.png
-%%DATADIR%%/cyclopentane.cml
-%%DATADIR%%/cyclopentane.png
-%%DATADIR%%/cyclopropane.cml
-%%DATADIR%%/cyclopropane.png
-%%DATADIR%%/cysteine.cml
-%%DATADIR%%/cytosine.cml
-%%DATADIR%%/d-fructose.cml
-%%DATADIR%%/d-glucose.cml
-%%DATADIR%%/dabcyl.cml
-%%DATADIR%%/dabsyl.cml
-%%DATADIR%%/dansyl.cml
-%%DATADIR%%/dashtool.png
-%%DATADIR%%/deoxyribose.cml
+%%DATADIR%%/LICENSE.txt
%%DATADIR%%/doc/COPYRIGHT.txt
-%%DATADIR%%/doc/GPL.txt
%%DATADIR%%/doc/HISTORY.txt
+%%DATADIR%%/doc/LICENSE.txt
%%DATADIR%%/doc/arrowtool.png
%%DATADIR%%/doc/boldtool.png
%%DATADIR%%/doc/brackettool.png
@@ -98,78 +50,7 @@ bin/xdrawchem
%%DATADIR%%/doc/toolmenu.html
%%DATADIR%%/doc/underlinetool.png
%%DATADIR%%/doc/uptool.png
-%%DATADIR%%/downtool.png
-%%DATADIR%%/edans.cml
-%%DATADIR%%/editcut.png
-%%DATADIR%%/editpaste.png
-%%DATADIR%%/erasetool.png
-%%DATADIR%%/filenew.png
-%%DATADIR%%/fileopen.png
-%%DATADIR%%/fileprint.png
-%%DATADIR%%/filesave.png
-%%DATADIR%%/fmoc.cml
-%%DATADIR%%/forward.xpm
-%%DATADIR%%/glutamic_acid.cml
-%%DATADIR%%/glutamine.cml
-%%DATADIR%%/glycine.cml
-%%DATADIR%%/guanine.cml
-%%DATADIR%%/histidine.cml
-%%DATADIR%%/home.xpm
-%%DATADIR%%/imidazole.cml
-%%DATADIR%%/imidazole.png
-%%DATADIR%%/indole.cml
-%%DATADIR%%/isoleucine.cml
-%%DATADIR%%/italictool.png
-%%DATADIR%%/justifycentertool.png
-%%DATADIR%%/justifylefttool.png
-%%DATADIR%%/justifyrighttool.png
-%%DATADIR%%/lassotool.png
-%%DATADIR%%/leucine.cml
-%%DATADIR%%/line1.png
-%%DATADIR%%/line2.png
-%%DATADIR%%/line3.png
-%%DATADIR%%/line4.png
-%%DATADIR%%/line5.png
-%%DATADIR%%/linetool.png
-%%DATADIR%%/lysine.cml
-%%DATADIR%%/mag_minus.png
-%%DATADIR%%/mag_plus.png
-%%DATADIR%%/methionine.cml
-%%DATADIR%%/naphthalene.cml
-%%DATADIR%%/nitrophenylalanine.cml
-%%DATADIR%%/pastetool.png
-%%DATADIR%%/phenylalanine.cml
-%%DATADIR%%/proline.cml
-%%DATADIR%%/purine.cml
-%%DATADIR%%/pyrimidine.cml
%%DATADIR%%/retro.txt
-%%DATADIR%%/ribose.cml
-%%DATADIR%%/ringtool.png
-%%DATADIR%%/selecttool.png
-%%DATADIR%%/serine.cml
-%%DATADIR%%/statine.cml
-%%DATADIR%%/steroid.cml
-%%DATADIR%%/subscript.png
-%%DATADIR%%/superscript.png
-%%DATADIR%%/sym_1e.png
-%%DATADIR%%/sym_2e.png
-%%DATADIR%%/sym_2e_line.png
-%%DATADIR%%/sym_delta_minus.png
-%%DATADIR%%/sym_delta_plus.png
-%%DATADIR%%/sym_minus.png
-%%DATADIR%%/sym_plus.png
-%%DATADIR%%/symboltool.png
-%%DATADIR%%/texttool.png
-%%DATADIR%%/threonine.cml
-%%DATADIR%%/thymine.cml
-%%DATADIR%%/tryptophan.cml
-%%DATADIR%%/tyrosine.cml
-%%DATADIR%%/underlinetool.png
-%%DATADIR%%/uptool.png
-%%DATADIR%%/uracil.cml
-%%DATADIR%%/valine.cml
-%%DATADIR%%/wavytool.png
-%%DATADIR%%/xdrawchem-icon.png
%%DATADIR%%/xdrawchem_da.qm
%%DATADIR%%/xdrawchem_de.qm
%%DATADIR%%/xdrawchem_en.qm