aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 11:50:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 11:50:58 +0000
commit19fb9b432be999e8d61c7892e6e3a884bf85ff4f (patch)
tree74eba052c6d25d4a6a8756c5bd25cf19cfb1f218 /science
parent7176acb592a62921bd872c40e3ba28cd1212d260 (diff)
downloadports-19fb9b432be999e8d61c7892e6e3a884bf85ff4f.tar.gz
ports-19fb9b432be999e8d61c7892e6e3a884bf85ff4f.zip
Fix build with GCC-based architectures for various kde@ ports.
- Qt5 required c++11 support. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> PR: 232726 PR: 232725 PR: 232723 PR: 232722 PR: 232721 PR: 232720 PR: 232719 PR: 232697 PR: 232682 PR: 232669 PR: 232668 PR: 232667 PR: 232666 PR: 232665 PR: 232664 PR: 232662 PR: 232661 PR: 232655 PR: 232654 PR: 232652 PR: 232648 PR: 232647 PR: 232641 PR: 232640 PR: 232638 PR: 232635 PR: 232634 PR: 232632 PR: 232631 PR: 232630 PR: 232629 PR: 232628 PR: 232627 PR: 232625 PR: 232624 PR: 232623 PR: 232614 PR: 232613 PR: 232612 PR: 232611 PR: 232610 PR: 232609 PR: 232607 PR: 232606 PR: 232605 PR: 232604 PR: 232603 PR: 232602 PR: 232597 PR: 232589 PR: 232585 PR: 232584 PR: 232583 PR: 232581 PR: 232580 PR: 232579 PR: 232578 PR: 232576 PR: 232575 PR: 232574 PR: 232573 PR: 232570
Notes
Notes: svn path=/head/; revision=483125
Diffstat (limited to 'science')
-rw-r--r--science/step/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/science/step/Makefile b/science/step/Makefile
index ee86b37c62c2..f79cc9c77c43 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -11,7 +11,8 @@ LIB_DEPENDS= libcln.so:math/cln \
libgsl.so:math/gsl \
libqalculate.so:math/libqalculate
-USES= cmake:outsource eigen:3 gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang eigen:3 gettext kde:5 \
+ pkgconfig qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons crash doctools ecm emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets js \
@@ -21,6 +22,10 @@ USE_KDE= attica auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network opengl printsupport qml quick svg \
widgets xml \
buildtools_build qmake_build
+CXXFLAGS_powerpc64= -Wno-error=return-type
+CXXFLAGS_powerpc= -Wno-error=return-type
+CXXFLAGS_powerpcspe= -Wno-error=return-type
+CXXFLAGS_sparc64= -Wno-error=return-type
OPTIONS_DEFINE= DOCS