aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 12:20:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 12:20:09 +0000
commit2a96318e2c78949241671de0f8b3d098c9a951df (patch)
treebafb6e085e1ddf1e0ef3946a1f4e8c69832f0888 /science
parent07a16e41aab9e49eda97e0d998bda16fc4a560c1 (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/py-hcluster/Makefile11
-rw-r--r--science/py-hcluster/files/patch-setup.py6
-rw-r--r--science/py-hcluster/pkg-descr2
3 files changed, 13 insertions, 6 deletions
diff --git a/science/py-hcluster/Makefile b/science/py-hcluster/Makefile
index b18c0c1f7dd7..9f6e11574f79 100644
--- a/science/py-hcluster/Makefile
+++ b/science/py-hcluster/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hcluster
PORTVERSION= 0.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,18 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Clustering Package For Scipy
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_hierarchy_wrap.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_distance_wrap.so
.include <bsd.port.mk>
diff --git a/science/py-hcluster/files/patch-setup.py b/science/py-hcluster/files/patch-setup.py
index ec3d32a78c22..f594433e9fbf 100644
--- a/science/py-hcluster/files/patch-setup.py
+++ b/science/py-hcluster/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2008-12-14 21:42:50.000000000 +0800
-+++ setup.py 2008-12-14 21:43:35.000000000 +0800
-@@ -33,7 +33,8 @@
+--- setup.py.orig 2008-12-14 09:19:42 UTC
++++ setup.py
+@@ -33,7 +33,8 @@ if len(valid_paths) > 1:
print string.join(l, '\n')
# Prompt the user with a list of selections.
while not (s >= 1 and s <= len(valid_paths)):
diff --git a/science/py-hcluster/pkg-descr b/science/py-hcluster/pkg-descr
index 650a24f72117..5a94cbb383a5 100644
--- a/science/py-hcluster/pkg-descr
+++ b/science/py-hcluster/pkg-descr
@@ -11,4 +11,4 @@ Toolbox API to make code easier to port from MATLAB to
Python/Numpy. The core implementation of this library
is in C for efficiency.
-WWW: http://code.google.com/p/scipy-cluster/
+WWW: http://code.google.com/p/scipy-cluster/