aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-02-14 00:54:34 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-02-14 00:54:34 +0000
commit7deb85057f19502967e9d016af0c1cf7df7d2b38 (patch)
treec3626aa8fc01fc56413320a3a5c422d73b2029f6 /science
parentfbb60722e82aa3c3716d22c860b1ea4d8042b050 (diff)
downloadports-7deb85057f19502967e9d016af0c1cf7df7d2b38.tar.gz
ports-7deb85057f19502967e9d016af0c1cf7df7d2b38.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/elmer-fem/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/science/elmer-fem/Makefile b/science/elmer-fem/Makefile
index 1f7cfde9e600..342317105c68 100644
--- a/science/elmer-fem/Makefile
+++ b/science/elmer-fem/Makefile
@@ -50,7 +50,7 @@ WITH_ATLAS= yes
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS= -lf77blas -latlas
-LAPACK= -lalapack
+LAPACK= -lalapack -lcblas
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
@@ -64,7 +64,10 @@ FCFLAGS+= -fPIC
FFLAGS+= -fPIC ${FCFLAGS}
.endif
CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FCFLAGS="${FCFLAGS}"
-CONFIGURE_ARGS+= --with-umfpack="-L${LOCALBASE} -lumfpack_elmer"
+CONFIGURE_ARGS+= --with-umfpack="-L${LOCALBASE}/lib -lumfpack_elmer" \
+ --with-blas="-L${LOCALBASE}/lib ${BLAS}" \
+ --with-lapack="-L${LOCALBASE}/lib ${LAPACK}" \
+ --with-eiof="-L${LOCALBASE}/lib -leiof"
pre-configure:
${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/tests/runtests.in