aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-18 21:21:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-18 21:21:17 +0000
commite3538c860fb9382e15f922f50c6ba1842664f643 (patch)
treebeb6b8377a38d8aa701054c3b6f2a1cc576cce5b /science
parente2592679992e4af696ed3d55878cbb14accd5802 (diff)
downloadports-e3538c860fb9382e15f922f50c6ba1842664f643.tar.gz
ports-e3538c860fb9382e15f922f50c6ba1842664f643.zip
New port: science/mmtf: C++ implementation of the MMTF API, decoder and encoder
Notes
Notes: svn path=/head/; revision=482378
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/mmtf/Makefile49
-rw-r--r--science/mmtf/distinfo5
-rw-r--r--science/mmtf/files/patch-tests_mmtf__tests.cpp11
-rw-r--r--science/mmtf/pkg-descr6
5 files changed, 72 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 2f713e25883b..136989c60bfb 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -142,6 +142,7 @@
SUBDIR += metaphysicl
SUBDIR += minc2
SUBDIR += mmdb2
+ SUBDIR += mmtf
SUBDIR += mol2ps
SUBDIR += molgif
SUBDIR += mpb
diff --git a/science/mmtf/Makefile b/science/mmtf/Makefile
new file mode 100644
index 000000000000..6cbff1437f54
--- /dev/null
+++ b/science/mmtf/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= mmtf
+DISTVERSION= g20180730
+CATEGORIES= science biology
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ implementation of the MMTF API, decoder and encoder
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${LOCALBASE}/include/msgpack.hpp:devel/msgpack
+
+USES= cmake:outsource compiler:c++11-lang localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= rcsb
+GH_PROJECT= mmtf-cpp
+GH_TAGNAME= 63e58a9
+GH_TUPLE= rcsb:mmtf:8c88834:x/mmtf_spec
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/mmtf.hpp \
+ include/mmtf/binary_decoder.hpp \
+ include/mmtf/binary_encoder.hpp \
+ include/mmtf/decoder.hpp \
+ include/mmtf/encoder.hpp \
+ include/mmtf/errors.hpp \
+ include/mmtf/export_helpers.hpp \
+ include/mmtf/map_decoder.hpp \
+ include/mmtf/msgpack_decoder.hpp \
+ include/mmtf/object_encoders.hpp \
+ include/mmtf/structure_data.hpp
+
+post-patch:
+ @cd ${WRKDIR} && ${LN} -s ${WRKSRC}/mmtf_spec # needed for testing
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dmmtf_build_local=ON -DBUILD_TESTS=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/science/mmtf/distinfo b/science/mmtf/distinfo
new file mode 100644
index 000000000000..c10212e02821
--- /dev/null
+++ b/science/mmtf/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1539895815
+SHA256 (rcsb-mmtf-cpp-g20180730-63e58a9_GH0.tar.gz) = 4570596c98ab520514b31f88c66478170123e4aa8f724c96e69d4973be6a527e
+SIZE (rcsb-mmtf-cpp-g20180730-63e58a9_GH0.tar.gz) = 58757
+SHA256 (rcsb-mmtf-8c88834_GH0.tar.gz) = 7c29eb9064e53ea447701b79764732a72ff53aa5adff25759e0e2b549c212cca
+SIZE (rcsb-mmtf-8c88834_GH0.tar.gz) = 34499239
diff --git a/science/mmtf/files/patch-tests_mmtf__tests.cpp b/science/mmtf/files/patch-tests_mmtf__tests.cpp
new file mode 100644
index 000000000000..e7e1d81127cc
--- /dev/null
+++ b/science/mmtf/files/patch-tests_mmtf__tests.cpp
@@ -0,0 +1,11 @@
+--- tests/mmtf_tests.cpp.orig 2018-10-18 20:26:48 UTC
++++ tests/mmtf_tests.cpp
+@@ -5,7 +5,7 @@
+ #define CATCH_CONFIG_MAIN
+ #endif
+
+-#include "catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <mmtf.hpp>
+ #include <mmtf/export_helpers.hpp>
diff --git a/science/mmtf/pkg-descr b/science/mmtf/pkg-descr
new file mode 100644
index 000000000000..d0b23bdfdd42
--- /dev/null
+++ b/science/mmtf/pkg-descr
@@ -0,0 +1,6 @@
+mmtf is a C++ headers-only decoder/encoder library for the MMTF format.
+
+The macromolecular transmission format (MMTF) is a binary encoding of chemical
+and biological structures.
+
+WWW: https://mmtf.rcsb.org/