aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-07-22 18:02:57 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-07-22 18:02:57 +0000
commit3331c8a7716c81408c95b29e0880f581a27045ca (patch)
treec8055779e7501099ffb1dba20975f7a0cd57f2e8 /science
parent9c5ac763dfdab76712ce58c6c0102234d59a85b5 (diff)
downloadports-3331c8a7716c81408c95b29e0880f581a27045ca.tar.gz
ports-3331c8a7716c81408c95b29e0880f581a27045ca.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/xfce4-equake-plugin/Makefile21
-rw-r--r--science/xfce4-equake-plugin/distinfo2
-rw-r--r--science/xfce4-equake-plugin/files/patch-panel-plugin__equake_applet.c22
-rw-r--r--science/xfce4-equake-plugin/pkg-descr4
-rw-r--r--science/xfce4-equake-plugin/pkg-plist7
6 files changed, 57 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 66b6c2828cac..ed138f961e56 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -187,6 +187,7 @@
SUBDIR += vmd
SUBDIR += voro++
SUBDIR += x11iraf
+ SUBDIR += xfce4-equake-plugin
SUBDIR += xmakemol
SUBDIR += xmds
diff --git a/science/xfce4-equake-plugin/Makefile b/science/xfce4-equake-plugin/Makefile
new file mode 100644
index 000000000000..7cc086ea6e5c
--- /dev/null
+++ b/science/xfce4-equake-plugin/Makefile
@@ -0,0 +1,21 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-equake-plugin
+PORTVERSION= 1.3.1
+CATEGORIES= science xfce
+MASTER_SITES= http://www.e-quake.org/wp-uploads/2013/07/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Earthquake monitor plugin for the Xfce desktop
+
+GNU_CONFIGURE= yes
+USES= gettext pkgconfig gmake
+USE_GNOME= glib20 gtk20 intltool intlhack
+USE_XFCE= configenv libmenu libutil panel
+USE_XORG= x11
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/science/xfce4-equake-plugin/distinfo b/science/xfce4-equake-plugin/distinfo
new file mode 100644
index 000000000000..85a48eb39bf3
--- /dev/null
+++ b/science/xfce4-equake-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-equake-plugin-1.3.1.tar.gz) = ca85a7c7af9337bb17d52f5a687209e310c4586d695dee6fc6aeed0a84a858ac
+SIZE (xfce4/xfce4-equake-plugin-1.3.1.tar.gz) = 478802
diff --git a/science/xfce4-equake-plugin/files/patch-panel-plugin__equake_applet.c b/science/xfce4-equake-plugin/files/patch-panel-plugin__equake_applet.c
new file mode 100644
index 000000000000..1f413aa17975
--- /dev/null
+++ b/science/xfce4-equake-plugin/files/patch-panel-plugin__equake_applet.c
@@ -0,0 +1,22 @@
+Avoid warning during compilation stage.
+
+--- ./panel-plugin/equake_applet.c.orig 2013-07-20 00:56:31.000000000 +0000
++++ ./panel-plugin/equake_applet.c 2013-07-20 15:58:24.000000000 +0000
+@@ -907,7 +907,7 @@
+ static void display_about_dialog(XfcePanelPlugin *applet, struct Equake_Data *equakedata)
+ {
+ GtkWidget *about;
+- gchar *auth[]={AUTHOR, NULL};
++ const gchar *auth[]={AUTHOR, NULL};
+
+ about=gtk_about_dialog_new();
+ if(about!=NULL)
+@@ -919,7 +919,7 @@
+ gtk_about_dialog_set_license((GtkAboutDialog*)about,LICENSE);
+ gtk_about_dialog_set_website((GtkAboutDialog*)about,WEBSITE);
+ gtk_about_dialog_set_website_label((GtkAboutDialog*)about,WEBSITELABEL);
+- gtk_about_dialog_set_authors((GtkAboutDialog*)about, (gchar*)auth);
++ gtk_about_dialog_set_authors((GtkAboutDialog*)about, (const gchar**)auth);
+
+ g_signal_connect_swapped(about, "response", G_CALLBACK (gtk_widget_destroy), about);
+ gtk_widget_show_all((GtkWidget*)about);
diff --git a/science/xfce4-equake-plugin/pkg-descr b/science/xfce4-equake-plugin/pkg-descr
new file mode 100644
index 000000000000..4833d54390df
--- /dev/null
+++ b/science/xfce4-equake-plugin/pkg-descr
@@ -0,0 +1,4 @@
+Equake is a panel plugin which monitors and displays earthquakes each time
+a new one occurs.
+
+WWW: http://freecode.com/projects/equake-xfce
diff --git a/science/xfce4-equake-plugin/pkg-plist b/science/xfce4-equake-plugin/pkg-plist
new file mode 100644
index 000000000000..2ddb9342be94
--- /dev/null
+++ b/science/xfce4-equake-plugin/pkg-plist
@@ -0,0 +1,7 @@
+lib/xfce4/panel-plugins/xfce4-equake-plugin
+share/icons/hicolor/48x48/apps/xfce4-equake-plugin-icon.png
+share/xfce4/panel-plugins/xfce4-equake-plugin.desktop
+@dirrmtry share/xfce4/panel-plugins
+@dirrmtry share/xfce4
+@dirrmtry lib/xfce4/panel-plugins
+@dirrmtry lib/xfce4