aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-02 18:52:07 +0000
commit4819ca343bfee8a3b54e7ff3ac26d280d1c1696f (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /science
parent49b7a7d4a4e27031eeb48b2c26d102a7f8527de9 (diff)
downloadports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.tar.gz
ports-4819ca343bfee8a3b54e7ff3ac26d280d1c1696f.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/p5-Algorithm-SVMLight/Makefile9
-rw-r--r--science/p5-Chemistry-Elements/Makefile9
-rw-r--r--science/p5-Chemistry-MacroMol/Makefile3
-rw-r--r--science/p5-Chemistry-Mol/Makefile3
-rw-r--r--science/p5-Geo-BUFR/Makefile3
-rw-r--r--science/p5-Geo-Coordinates-Converter/Makefile3
-rw-r--r--science/p5-Geo-WebService-Elevation-USGS/Makefile3
7 files changed, 16 insertions, 17 deletions
diff --git a/science/p5-Algorithm-SVMLight/Makefile b/science/p5-Algorithm-SVMLight/Makefile
index 2e2288bf7c87..b52486afd561 100644
--- a/science/p5-Algorithm-SVMLight/Makefile
+++ b/science/p5-Algorithm-SVMLight/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Algorithm-SVMLight
-# Date created: 2006-07-18
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Algorithm-SVMLight
PORTVERSION= 0.09
@@ -17,7 +13,8 @@ COMMENT= Perl interface to SVMLight Machine-Learning Package
BUILD_DEPENDS= svmlight>=6.01_2:${PORTSDIR}/science/svmlight
LIB_DEPENDS= svmlight:${PORTSDIR}/science/svmlight
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Algorithm::SVMLight.3
diff --git a/science/p5-Chemistry-Elements/Makefile b/science/p5-Chemistry-Elements/Makefile
index 8ccaeafc3078..7e94a5e423ee 100644
--- a/science/p5-Chemistry-Elements/Makefile
+++ b/science/p5-Chemistry-Elements/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Chemistry::Elements
-# Date created: 31 Dec 2001
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Chemistry-Elements
PORTVERSION= 1.07
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for working with Chemical Elements
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Chemistry::Elements.3
diff --git a/science/p5-Chemistry-MacroMol/Makefile b/science/p5-Chemistry-MacroMol/Makefile
index 2ae15d10ff30..fb7e109059c3 100644
--- a/science/p5-Chemistry-MacroMol/Makefile
+++ b/science/p5-Chemistry-MacroMol/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl toolkit to describe macromolecules
BUILD_DEPENDS= p5-Chemistry-Mol>=0.37:${PORTSDIR}/science/p5-Chemistry-Mol
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Chemistry::MacroMol.3 Chemistry::Domain.3
diff --git a/science/p5-Chemistry-Mol/Makefile b/science/p5-Chemistry-Mol/Makefile
index e9cbb6930fc3..2adc9487312b 100644
--- a/science/p5-Chemistry-Mol/Makefile
+++ b/science/p5-Chemistry-Mol/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl toolkit to describe molecules
BUILD_DEPENDS= p5-Math-VectorReal>=1.02:${PORTSDIR}/math/p5-Math-VectorReal
RUN_DEPENDS= p5-Math-VectorReal>=1.02:${PORTSDIR}/math/p5-Math-VectorReal
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Chemistry::Atom.3 Chemistry::Bond.3 \
Chemistry::Obj.3 Chemistry::File.3 \
diff --git a/science/p5-Geo-BUFR/Makefile b/science/p5-Geo-BUFR/Makefile
index b6d6b6cc123a..43e8687968ae 100644
--- a/science/p5-Geo-BUFR/Makefile
+++ b/science/p5-Geo-BUFR/Makefile
@@ -27,6 +27,7 @@ MAN3= Geo::BUFR.3 \
Geo::bufralter.3 \
Geo::bufrencode.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/science/p5-Geo-Coordinates-Converter/Makefile b/science/p5-Geo-Coordinates-Converter/Makefile
index 8c92743e5488..6cd9f74acbe7 100644
--- a/science/p5-Geo-Coordinates-Converter/Makefile
+++ b/science/p5-Geo-Coordinates-Converter/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Base>0:${PORTSDIR}/devel/p5-Test-Base
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Coordinates::Converter::Datum.3 \
Geo::Coordinates::Converter.3 \
diff --git a/science/p5-Geo-WebService-Elevation-USGS/Makefile b/science/p5-Geo-WebService-Elevation-USGS/Makefile
index eef1c52f3c0c..e06831e7ca43 100644
--- a/science/p5-Geo-WebService-Elevation-USGS/Makefile
+++ b/science/p5-Geo-WebService-Elevation-USGS/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::WebService::Elevation::USGS.3