aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-07-14 09:51:49 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-07-14 09:51:49 +0000
commit269ae10910a62a93f60a11dce840dc72f5e6856a (patch)
tree604ea27f2de1ddad291b407a0473d75fa9b26141 /science
parent80b36c230633f488d3a8b3b49d753d7feb628224 (diff)
downloadports-269ae10910a62a93f60a11dce840dc72f5e6856a.tar.gz
ports-269ae10910a62a93f60a11dce840dc72f5e6856a.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/libghemical/Makefile5
-rw-r--r--science/oof/Makefile6
2 files changed, 4 insertions, 7 deletions
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 26def8dc7fdc..4fa2c85c7efe 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -27,10 +27,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
diff --git a/science/oof/Makefile b/science/oof/Makefile
index 1f240e8f818d..db5d471b0898 100644
--- a/science/oof/Makefile
+++ b/science/oof/Makefile
@@ -27,9 +27,9 @@ LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIBS= -lblas
.endif
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FORTRANLIBDIR= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``
-FORTRANLIBDIR2= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``/../../../
+USE_FORTRAN= yes
+FORTRANLIBDIR= `${DIRNAME} \`${FC} -print-libgcc-file-name\``
+FORTRANLIBDIR2= `${DIRNAME} \`${FC} -print-libgcc-file-name\``/../../../
FORTRANLIBS= -lgfortranbegin -lgfortran
CXXFLAGS+= -DDONT_HAVE_STRSTREAM_H -DNEED_FDSTREAM